Put back 2.6.24 files as well
SVN-Revision: 11593
This commit is contained in:
parent
9e151671a9
commit
310c6108cd
13 changed files with 1789 additions and 0 deletions
24
target/linux/rdc/files/arch/x86/kernel/cpu/rdc.c
Normal file
24
target/linux/rdc/files/arch/x86/kernel/cpu/rdc.c
Normal file
|
@ -0,0 +1,24 @@
|
|||
#include <linux/init.h>
|
||||
#include <linux/bitops.h>
|
||||
#include <linux/mm.h>
|
||||
#include <asm/io.h>
|
||||
#include <asm/processor.h>
|
||||
|
||||
#include "cpu.h"
|
||||
|
||||
static struct cpu_dev rdc_cpu_dev __cpuinitdata = {
|
||||
.c_vendor = "RDC",
|
||||
.c_models = {
|
||||
{ .vendor = X86_VENDOR_RDC, .family = 4, .model_names =
|
||||
{
|
||||
[0] = "R861x(-G)",
|
||||
}
|
||||
},
|
||||
},
|
||||
};
|
||||
|
||||
int __init rdc_init_cpu(void)
|
||||
{
|
||||
cpu_devs[X86_VENDOR_RDC] = &rdc_cpu_dev;
|
||||
return 0;
|
||||
}
|
5
target/linux/rdc/files/arch/x86/mach-rdc/Makefile
Normal file
5
target/linux/rdc/files/arch/x86/mach-rdc/Makefile
Normal file
|
@ -0,0 +1,5 @@
|
|||
#
|
||||
# Makefile for the RDC321x specific parts of the kernel
|
||||
#
|
||||
obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o
|
||||
|
91
target/linux/rdc/files/arch/x86/mach-rdc/gpio.c
Normal file
91
target/linux/rdc/files/arch/x86/mach-rdc/gpio.c
Normal file
|
@ -0,0 +1,91 @@
|
|||
/*
|
||||
* Copyright (C) 2007, OpenWrt.org, Florian Fainelli <florian@openwrt.org>
|
||||
* RDC321x architecture specific GPIO support
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License as published by the
|
||||
* Free Software Foundation; either version 2 of the License, or (at your
|
||||
* option) any later version.
|
||||
*/
|
||||
|
||||
#include <linux/autoconf.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/io.h>
|
||||
#include <linux/types.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/delay.h>
|
||||
|
||||
#include <asm/mach-rdc/rdc321x_defs.h>
|
||||
|
||||
static inline int rdc_gpio_is_valid(unsigned gpio)
|
||||
{
|
||||
return (gpio <= RDC_MAX_GPIO);
|
||||
}
|
||||
|
||||
static unsigned int rdc_gpio_read(unsigned gpio)
|
||||
{
|
||||
unsigned int val;
|
||||
|
||||
val = 0x80000000 | (7 << 11) | ((gpio&0x20?0x84:0x48));
|
||||
outl(val, RDC3210_CFGREG_ADDR);
|
||||
udelay(10);
|
||||
val = inl(RDC3210_CFGREG_DATA);
|
||||
val |= (0x1 << (gpio & 0x1F));
|
||||
outl(val, RDC3210_CFGREG_DATA);
|
||||
udelay(10);
|
||||
val = 0x80000000 | (7 << 11) | ((gpio&0x20?0x88:0x4C));
|
||||
outl(val, RDC3210_CFGREG_ADDR);
|
||||
udelay(10);
|
||||
val = inl(RDC3210_CFGREG_DATA);
|
||||
|
||||
return val;
|
||||
}
|
||||
|
||||
static void rdc_gpio_write(unsigned int val)
|
||||
{
|
||||
if (val) {
|
||||
outl(val, RDC3210_CFGREG_DATA);
|
||||
udelay(10);
|
||||
}
|
||||
}
|
||||
|
||||
int rdc_gpio_get_value(unsigned gpio)
|
||||
{
|
||||
if (rdc_gpio_is_valid(gpio))
|
||||
return (int)rdc_gpio_read(gpio);
|
||||
else
|
||||
return -EINVAL;
|
||||
}
|
||||
EXPORT_SYMBOL(rdc_gpio_get_value);
|
||||
|
||||
void rdc_gpio_set_value(unsigned gpio, int value)
|
||||
{
|
||||
unsigned int val;
|
||||
|
||||
if (!rdc_gpio_is_valid(gpio))
|
||||
return;
|
||||
|
||||
val = rdc_gpio_read(gpio);
|
||||
|
||||
if (value)
|
||||
val &= ~(0x1 << (gpio & 0x1F));
|
||||
else
|
||||
val |= (0x1 << (gpio & 0x1F));
|
||||
|
||||
rdc_gpio_write(val);
|
||||
}
|
||||
EXPORT_SYMBOL(rdc_gpio_set_value);
|
||||
|
||||
int rdc_gpio_direction_input(unsigned gpio)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
EXPORT_SYMBOL(rdc_gpio_direction_input);
|
||||
|
||||
int rdc_gpio_direction_output(unsigned gpio, int value)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
EXPORT_SYMBOL(rdc_gpio_direction_output);
|
||||
|
||||
|
114
target/linux/rdc/files/arch/x86/mach-rdc/platform.c
Normal file
114
target/linux/rdc/files/arch/x86/mach-rdc/platform.c
Normal file
|
@ -0,0 +1,114 @@
|
|||
/*
|
||||
* $Id: platform.c 8331 2007-08-03 15:59:23Z florian $
|
||||
*
|
||||
* Generic RDC321x platform devices
|
||||
*
|
||||
* Copyright (C) 2007 OpenWrt.org
|
||||
* Copyright (C) 2007 Florian Fainelli <florian@openwrt.org>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU General Public License
|
||||
* as published by the Free Software Foundation; either version 2
|
||||
* of the License, or (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
* but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the
|
||||
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
*/
|
||||
|
||||
#include <linux/init.h>
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/list.h>
|
||||
#include <linux/device.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/version.h>
|
||||
#include <linux/leds.h>
|
||||
#include <linux/gpio_keys.h>
|
||||
#include <linux/input.h>
|
||||
|
||||
#include <asm/gpio.h>
|
||||
|
||||
/* Flash */
|
||||
static struct resource rdc_flash_resource[] = {
|
||||
[0] = {
|
||||
.start = (u32)-CONFIG_MTD_RDC3210_SIZE,
|
||||
.end = (u32)-1,
|
||||
.flags = IORESOURCE_MEM,
|
||||
},
|
||||
};
|
||||
|
||||
static struct platform_device rdc_flash_device = {
|
||||
.name = "rdc321x-flash",
|
||||
.id = -1,
|
||||
.num_resources = ARRAY_SIZE(rdc_flash_resource),
|
||||
.resource = rdc_flash_resource,
|
||||
};
|
||||
|
||||
/* LEDS */
|
||||
static struct gpio_led default_leds[] = {
|
||||
{ .name = "rdc321x:dmz", .gpio = 1, },
|
||||
};
|
||||
|
||||
static struct gpio_led_platform_data rdc321x_led_data = {
|
||||
.num_leds = ARRAY_SIZE(default_leds),
|
||||
.leds = default_leds,
|
||||
};
|
||||
|
||||
static struct platform_device rdc321x_leds = {
|
||||
.name = "leds-gpio",
|
||||
.id = -1,
|
||||
.dev = {
|
||||
.platform_data = &rdc321x_led_data,
|
||||
}
|
||||
};
|
||||
|
||||
/* Watchdog */
|
||||
static struct platform_device rdc321x_wdt = {
|
||||
.name = "rdc321x-wdt",
|
||||
.id = -1,
|
||||
.num_resources = 0,
|
||||
};
|
||||
|
||||
/* Button */
|
||||
static struct gpio_keys_button rdc321x_gpio_btn[] = {
|
||||
{
|
||||
.gpio = 0,
|
||||
.code = BTN_0,
|
||||
.desc = "Reset",
|
||||
.active_low = 1,
|
||||
}
|
||||
};
|
||||
|
||||
static struct gpio_keys_platform_data rdc321x_gpio_btn_data = {
|
||||
.buttons = rdc321x_gpio_btn,
|
||||
.nbuttons = ARRAY_SIZE(rdc321x_gpio_btn),
|
||||
};
|
||||
|
||||
static struct platform_device rdc321x_button = {
|
||||
.name = "gpio-keys",
|
||||
.id = -1,
|
||||
.dev = {
|
||||
.platform_data = &rdc321x_gpio_btn_data,
|
||||
}
|
||||
};
|
||||
|
||||
static struct platform_device *rdc321x_devs[] = {
|
||||
&rdc_flash_device,
|
||||
&rdc321x_leds,
|
||||
&rdc321x_wdt,
|
||||
&rdc321x_button
|
||||
};
|
||||
|
||||
static int __init rdc_board_setup(void)
|
||||
{
|
||||
return platform_add_devices(rdc321x_devs, ARRAY_SIZE(rdc321x_devs));
|
||||
}
|
||||
|
||||
arch_initcall(rdc_board_setup);
|
14
target/linux/rdc/files/arch/x86/mach-rdc/setup.c
Normal file
14
target/linux/rdc/files/arch/x86/mach-rdc/setup.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
/*
|
||||
* Machine specific setup for generic
|
||||
*/
|
||||
|
||||
#include <linux/init.h>
|
||||
#include <linux/interrupt.h>
|
||||
#include <asm/arch_hooks.h>
|
||||
#include <asm/io.h>
|
||||
#include <asm/setup.h>
|
||||
|
||||
char * __init machine_specific_memory_setup(void)
|
||||
{
|
||||
return "RDC R-321x";
|
||||
}
|
272
target/linux/rdc/files/arch/x86/mach-rdc/wdt.c
Normal file
272
target/linux/rdc/files/arch/x86/mach-rdc/wdt.c
Normal file
|
@ -0,0 +1,272 @@
|
|||
/*
|
||||
* RDC321x watchdog driver
|
||||
*
|
||||
* Copyright (C) 2007 Florian Fainelli <florian@openwrt.org>
|
||||
*
|
||||
* This driver is highly inspired from the cpu5_wdt driver
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify
|
||||
* it under the terms of the GNU General Public License as published by
|
||||
* the Free Software Foundation; either version 2 of the License, or
|
||||
* (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
* but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the Free Software
|
||||
* Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
*
|
||||
*/
|
||||
|
||||
#include <linux/module.h>
|
||||
#include <linux/moduleparam.h>
|
||||
#include <linux/types.h>
|
||||
#include <linux/errno.h>
|
||||
#include <linux/miscdevice.h>
|
||||
#include <linux/fs.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/ioport.h>
|
||||
#include <linux/timer.h>
|
||||
#include <linux/completion.h>
|
||||
#include <linux/jiffies.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/watchdog.h>
|
||||
|
||||
#include <asm/io.h>
|
||||
#include <asm/uaccess.h>
|
||||
|
||||
#include <asm/mach-rdc/rdc321x_defs.h>
|
||||
|
||||
#define RDC_WDT_MASK 0x80000000 /* Mask */
|
||||
#define RDC_WDT_EN 0x00800000 /* Enable bit */
|
||||
#define RDC_WDT_WTI 0x00200000 /* Generate a CPU reset/NMI/WDT irq when WDT timeout is reached */
|
||||
#define RDC_WDT_RST 0x00100000 /* Reset bit */
|
||||
#define RDC_WDT_WIF 0x00040000 /* WDT IRQ Flag */
|
||||
#define RDC_WDT_IRT 0x00000100 /* IRQ Routing table */
|
||||
#define RDC_WDT_CNT 0x00000001 /* WDT count */
|
||||
|
||||
#define RDC_CLS_TMR 0x80003844 /* Clear timer */
|
||||
|
||||
#define RDC_WDT_INTERVAL (HZ/10+1)
|
||||
|
||||
int nowayout = WATCHDOG_NOWAYOUT;
|
||||
module_param(nowayout, int, 0);
|
||||
MODULE_PARM_DESC(nowayout, "Watchdog cannot be stopped once started (default=" __MODULE_STRING(WATCHDOG_NOWAYOUT) ")");
|
||||
|
||||
static int ticks = 1000;
|
||||
|
||||
/* some device data */
|
||||
|
||||
static struct {
|
||||
struct completion stop;
|
||||
volatile int running;
|
||||
struct timer_list timer;
|
||||
volatile int queue;
|
||||
int default_ticks;
|
||||
unsigned long inuse;
|
||||
} rdc321x_wdt_device;
|
||||
|
||||
/* generic helper functions */
|
||||
|
||||
static void rdc321x_wdt_trigger(unsigned long unused)
|
||||
{
|
||||
if( rdc321x_wdt_device.running )
|
||||
ticks--;
|
||||
|
||||
/* keep watchdog alive */
|
||||
outl(RDC_WDT_EN|inl(RDC3210_CFGREG_DATA), RDC3210_CFGREG_DATA);
|
||||
|
||||
/* requeue?? */
|
||||
if (rdc321x_wdt_device.queue && ticks)
|
||||
mod_timer(&rdc321x_wdt_device.timer, jiffies + RDC_WDT_INTERVAL);
|
||||
else {
|
||||
/* ticks doesn't matter anyway */
|
||||
complete(&rdc321x_wdt_device.stop);
|
||||
}
|
||||
|
||||
}
|
||||
|
||||
static void rdc321x_wdt_reset(void)
|
||||
{
|
||||
ticks = rdc321x_wdt_device.default_ticks;
|
||||
}
|
||||
|
||||
static void rdc321x_wdt_start(void)
|
||||
{
|
||||
if (!rdc321x_wdt_device.queue) {
|
||||
rdc321x_wdt_device.queue = 1;
|
||||
|
||||
/* Clear the timer */
|
||||
outl(RDC_CLS_TMR, RDC3210_CFGREG_ADDR);
|
||||
|
||||
/* Enable watchdog and set the timeout to 81.92 us */
|
||||
outl(RDC_WDT_EN|RDC_WDT_CNT, RDC3210_CFGREG_DATA);
|
||||
|
||||
mod_timer(&rdc321x_wdt_device.timer, jiffies + RDC_WDT_INTERVAL);
|
||||
}
|
||||
|
||||
/* if process dies, counter is not decremented */
|
||||
rdc321x_wdt_device.running++;
|
||||
}
|
||||
|
||||
static int rdc321x_wdt_stop(void)
|
||||
{
|
||||
if (rdc321x_wdt_device.running)
|
||||
rdc321x_wdt_device.running = 0;
|
||||
|
||||
ticks = rdc321x_wdt_device.default_ticks;
|
||||
|
||||
return -EIO;
|
||||
}
|
||||
|
||||
/* filesystem operations */
|
||||
|
||||
static int rdc321x_wdt_open(struct inode *inode, struct file *file)
|
||||
{
|
||||
if (test_and_set_bit(0, &rdc321x_wdt_device.inuse))
|
||||
return -EBUSY;
|
||||
|
||||
return nonseekable_open(inode, file);
|
||||
}
|
||||
|
||||
static int rdc321x_wdt_release(struct inode *inode, struct file *file)
|
||||
{
|
||||
clear_bit(0, &rdc321x_wdt_device.inuse);
|
||||
return 0;
|
||||
}
|
||||
|
||||
static int rdc321x_wdt_ioctl(struct inode *inode, struct file *file, unsigned int cmd, unsigned long arg)
|
||||
{
|
||||
void __user *argp = (void __user *)arg;
|
||||
unsigned int value;
|
||||
static struct watchdog_info ident =
|
||||
{
|
||||
.options = WDIOF_CARDRESET,
|
||||
.identity = "RDC321x WDT",
|
||||
};
|
||||
|
||||
switch(cmd) {
|
||||
case WDIOC_KEEPALIVE:
|
||||
rdc321x_wdt_reset();
|
||||
break;
|
||||
case WDIOC_GETSTATUS:
|
||||
/* Read the value from the DATA register */
|
||||
value = inl(RDC3210_CFGREG_DATA);
|
||||
if ( copy_to_user(argp, &value, sizeof(int)) )
|
||||
return -EFAULT;
|
||||
break;
|
||||
case WDIOC_GETSUPPORT:
|
||||
if ( copy_to_user(argp, &ident, sizeof(ident)) )
|
||||
return -EFAULT;
|
||||
break;
|
||||
case WDIOC_SETOPTIONS:
|
||||
if ( copy_from_user(&value, argp, sizeof(int)) )
|
||||
return -EFAULT;
|
||||
switch(value) {
|
||||
case WDIOS_ENABLECARD:
|
||||
rdc321x_wdt_start();
|
||||
break;
|
||||
case WDIOS_DISABLECARD:
|
||||
return rdc321x_wdt_stop();
|
||||
default:
|
||||
return -EINVAL;
|
||||
}
|
||||
break;
|
||||
default:
|
||||
return -ENOTTY;
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
|
||||
static ssize_t rdc321x_wdt_write(struct file *file, const char __user *buf, size_t count, loff_t *ppos)
|
||||
{
|
||||
if ( !count )
|
||||
return -EIO;
|
||||
|
||||
rdc321x_wdt_reset();
|
||||
|
||||
return count;
|
||||
}
|
||||
|
||||
static const struct file_operations rdc321x_wdt_fops = {
|
||||
.owner = THIS_MODULE,
|
||||
.llseek = no_llseek,
|
||||
.ioctl = rdc321x_wdt_ioctl,
|
||||
.open = rdc321x_wdt_open,
|
||||
.write = rdc321x_wdt_write,
|
||||
.release = rdc321x_wdt_release,
|
||||
};
|
||||
|
||||
static struct miscdevice rdc321x_wdt_misc = {
|
||||
.minor = WATCHDOG_MINOR,
|
||||
.name = "watchdog",
|
||||
.fops = &rdc321x_wdt_fops,
|
||||
};
|
||||
|
||||
static int __devinit rdc321x_wdt_probe(struct platform_device *pdev)
|
||||
{
|
||||
int err;
|
||||
|
||||
if ( (err = misc_register(&rdc321x_wdt_misc)) < 0 ) {
|
||||
printk(KERN_ERR PFX "misc_register failed\n");
|
||||
return err;
|
||||
}
|
||||
|
||||
/* Reset the watchdog */
|
||||
outl(RDC_WDT_RST, RDC3210_CFGREG_DATA);
|
||||
|
||||
init_completion(&rdc321x_wdt_device.stop);
|
||||
rdc321x_wdt_device.queue = 0;
|
||||
|
||||
clear_bit(0, &rdc321x_wdt_device.inuse);
|
||||
|
||||
setup_timer(&rdc321x_wdt_device.timer, rdc321x_wdt_trigger, 0);
|
||||
|
||||
rdc321x_wdt_device.default_ticks = ticks;
|
||||
|
||||
printk(KERN_INFO PFX "init success\n");
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
static int rdc321x_wdt_remove(struct platform_device *pdev)
|
||||
{
|
||||
if (rdc321x_wdt_device.queue) {
|
||||
rdc321x_wdt_device.queue = 0;
|
||||
wait_for_completion(&rdc321x_wdt_device.stop);
|
||||
}
|
||||
|
||||
misc_deregister(&rdc321x_wdt_misc);
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
static struct platform_driver rdc321x_wdt_driver = {
|
||||
.probe = rdc321x_wdt_probe,
|
||||
.remove = rdc321x_wdt_remove,
|
||||
.driver = {
|
||||
.owner = THIS_MODULE,
|
||||
.name = "rdc321x-wdt",
|
||||
},
|
||||
};
|
||||
|
||||
static int __init rdc321x_wdt_init(void)
|
||||
{
|
||||
return platform_driver_register(&rdc321x_wdt_driver);
|
||||
}
|
||||
|
||||
static void __exit rdc321x_wdt_exit(void)
|
||||
{
|
||||
platform_driver_unregister(&rdc321x_wdt_driver);
|
||||
}
|
||||
|
||||
module_init(rdc321x_wdt_init);
|
||||
module_exit(rdc321x_wdt_exit);
|
||||
|
||||
MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>");
|
||||
MODULE_DESCRIPTION("RDC321x watchdog driver");
|
||||
MODULE_LICENSE("GPL");
|
||||
MODULE_ALIAS_MISCDEV(WATCHDOG_MINOR);
|
65
target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
Normal file
65
target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
Normal file
|
@ -0,0 +1,65 @@
|
|||
diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
|
||||
--- linux-2.6.17/drivers/mtd/maps/Kconfig 2006-06-18 03:49:35.000000000 +0200
|
||||
+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig 2006-09-24 20:28:11.000000000 +0200
|
||||
@@ -76,6 +76,50 @@
|
||||
PNC-2000 is the name of Network Camera product from PHOTRON
|
||||
Ltd. in Japan. It uses CFI-compliant flash.
|
||||
|
||||
+config MTD_RDC3210
|
||||
+ tristate "CFI Flash device mapped on RDC3210"
|
||||
+ depends on X86 && MTD_CFI && MTD_PARTITIONS
|
||||
+ help
|
||||
+ RDC-3210 is the flash device we find on Ralink reference board.
|
||||
+
|
||||
+config MTD_RDC3210_STATIC_MAP
|
||||
+ bool "Partitions on RDC3210 mapped statically" if MTD_RDC3210
|
||||
+ select MTD_RDC3210_FACTORY_PRESENT
|
||||
+ help
|
||||
+ The mapping driver will use the static partition map for the
|
||||
+ RDC-3210 flash device.
|
||||
+
|
||||
+config MTD_RDC3210_FACTORY_PRESENT
|
||||
+ bool "Reserve a partition on RDC3210 for factory presets"
|
||||
+ depends on MTD_RDC3210
|
||||
+ default y
|
||||
+ help
|
||||
+ The mapping driver will reserve a partition on the RDC-3210 flash
|
||||
+ device for resetting flash contents to factory defaults.
|
||||
+
|
||||
+config MTD_RDC3210_ALLOW_JFFS2
|
||||
+ bool "JFFS2 filesystem usable in a partition on RDC3210"
|
||||
+ depends on MTD_RDC3210 && !MTD_RDC3210_STATIC_MAP
|
||||
+ help
|
||||
+ The mapping driver will align a partition on the RDC-3210 flash
|
||||
+ device to an erase-block boundary so that a JFFS2 filesystem may
|
||||
+ reside on it.
|
||||
+
|
||||
+config MTD_RDC3210_SIZE
|
||||
+ hex "Amount of flash memory on RDC3210"
|
||||
+ depends on MTD_RDC3210
|
||||
+ default "0x400000"
|
||||
+ help
|
||||
+ Total size in bytes of the RDC-3210 flash device
|
||||
+
|
||||
+config MTD_RDC3210_BUSWIDTH
|
||||
+ int "Width of CFI Flash device mapped on RDC3210"
|
||||
+ depends on MTD_RDC3210
|
||||
+ default "2"
|
||||
+ help
|
||||
+ Number of bytes addressed on the RDC-3210 flash device before
|
||||
+ addressing the same chip again
|
||||
+
|
||||
config MTD_SC520CDP
|
||||
tristate "CFI Flash device mapped on AMD SC520 CDP"
|
||||
depends on X86 && MTD_CFI && MTD_CONCAT
|
||||
diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
|
||||
--- linux-2.6.17/drivers/mtd/maps/Makefile 2006-06-18 03:49:35.000000000 +0200
|
||||
+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
obj-$(CONFIG_MTD_PHYSMAP) += physmap.o
|
||||
obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
|
||||
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
|
||||
+obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
|
||||
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
|
||||
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
|
||||
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
|
15
target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
Normal file
15
target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||
index 97b64d7..f8c1d32 100644
|
||||
--- a/arch/x86/Kconfig
|
||||
+++ b/arch/x86/Kconfig
|
||||
@@ -79,6 +79,10 @@ config GENERIC_BUG
|
||||
default y
|
||||
depends on BUG
|
||||
|
||||
+config GENERIC_GPIO
|
||||
+ bool
|
||||
+ default n
|
||||
+
|
||||
config GENERIC_HWEIGHT
|
||||
bool
|
||||
default y
|
39
target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
Normal file
39
target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
|
||||
--- linux-2.6.17/drivers/net/Kconfig 2006-06-18 03:49:35.000000000 +0200
|
||||
+++ linux-2.6.17.new/drivers/net/Kconfig 2006-09-25 13:14:27.000000000 +0200
|
||||
@@ -1358,6 +1358,24 @@
|
||||
<file:Documentation/networking/net-modules.txt>. The module will be
|
||||
called apricot.
|
||||
|
||||
+config R6040
|
||||
+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
|
||||
+ depends on NET_PCI && EXPERIMENTAL
|
||||
+ select MII
|
||||
+ help
|
||||
+ If you have a network (Ethernet) controller of this type, say Y and
|
||||
+ read the Ethernet-HOWTO, available from
|
||||
+ <http://www.tldp.org/docs.html#howto>.
|
||||
+
|
||||
+ To compile this driver as a module, choose M here and read
|
||||
+ <file:Documentation/networking/net-modules.txt>. The module will be
|
||||
+ called r6040.
|
||||
+
|
||||
+
|
||||
+config R6040_NAPI
|
||||
+ bool "NAPI support for R6040"
|
||||
+ depends on R6040
|
||||
+ default y
|
||||
config B44
|
||||
tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
|
||||
depends on NET_PCI && PCI && EXPERIMENTAL
|
||||
diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
|
||||
--- linux-2.6.17/drivers/net/Makefile 2006-06-18 03:49:35.000000000 +0200
|
||||
+++ linux-2.6.17.new/drivers/net/Makefile 2006-09-25 13:14:45.000000000 +0200
|
||||
@@ -106,6 +106,7 @@
|
||||
obj-$(CONFIG_NE3210) += ne3210.o 8390.o
|
||||
obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
|
||||
obj-$(CONFIG_B44) += b44.o
|
||||
+obj-$(CONFIG_R6040) += r6040.o
|
||||
obj-$(CONFIG_FORCEDETH) += forcedeth.o
|
||||
obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o
|
||||
|
11
target/linux/rdc/patches-2.6.24/003-rootfstype.patch
Normal file
11
target/linux/rdc/patches-2.6.24/003-rootfstype.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- linux-2.6.19.2/init/do_mounts.c 2007-01-10 11:10:37.000000000 -0800
|
||||
+++ foo/init/do_mounts.c 2007-04-05 13:15:37.000000000 -0700
|
||||
@@ -243,6 +243,8 @@
|
||||
{
|
||||
char *s = page;
|
||||
|
||||
+ if (!root_fs_names)
|
||||
+ root_fs_names = "squashfs,jffs2";
|
||||
if (root_fs_names) {
|
||||
strcpy(page, root_fs_names);
|
||||
while (*s++) {
|
77
target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
Normal file
77
target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
Normal file
|
@ -0,0 +1,77 @@
|
|||
diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
|
||||
--- linux-2.6.24/arch/x86/Kconfig 2008-01-24 23:58:37.000000000 +0100
|
||||
+++ linux-2.6.24.new/arch/x86/Kconfig 2008-02-11 18:24:27.000000000 +0100
|
||||
@@ -300,6 +300,17 @@
|
||||
supposed to run on these EM64T-based machines. Only choose this option
|
||||
if you have one of these machines.
|
||||
|
||||
+config X86_RDC
|
||||
+ bool "Support for RDC 3211 boards"
|
||||
+ select GENERIC_GPIO
|
||||
+ select LEDS_GPIO
|
||||
+ select LEDS_CLASS
|
||||
+ help
|
||||
+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
|
||||
+ supposed to run on an IA-32 RDC R3211 system.
|
||||
+ Only choose this option if you have such as system, otherwise you
|
||||
+ should say N here.
|
||||
+
|
||||
endchoice
|
||||
|
||||
config SCHED_NO_NO_OMIT_FRAME_POINTER
|
||||
diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c
|
||||
--- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c 2008-01-24 23:58:37.000000000 +0100
|
||||
+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c 2008-02-11 18:26:18.000000000 +0100
|
||||
@@ -30,6 +30,17 @@
|
||||
udelay(50); /* shouldn't get here but be safe and spin a while */
|
||||
}
|
||||
|
||||
+static void r8610_reset(struct pci_dev *dev)
|
||||
+{
|
||||
+ int i;
|
||||
+
|
||||
+ outl(0x80003840,0xCF8);
|
||||
+ i=inl(0xCFC);
|
||||
+ i |= 0x1600;
|
||||
+ outl(i,0xCFC);
|
||||
+ outb(1,0x92);
|
||||
+}
|
||||
+
|
||||
struct device_fixup {
|
||||
unsigned int vendor;
|
||||
unsigned int device;
|
||||
@@ -40,6 +51,7 @@
|
||||
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
|
||||
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
|
||||
{ PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
|
||||
+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6030, r8610_reset },
|
||||
};
|
||||
|
||||
/*
|
||||
diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32
|
||||
--- linux-2.6.24/arch/x86/Makefile_32 2008-01-24 23:58:37.000000000 +0100
|
||||
+++ linux-2.6.24.new/arch/x86/Makefile_32 2008-02-11 18:25:12.000000000 +0100
|
||||
@@ -99,6 +99,11 @@
|
||||
mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
|
||||
core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
|
||||
|
||||
+# RDC subarch support
|
||||
+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-x86/mach-rdc
|
||||
+mcore-$(CONFIG_X86_RDC) := arch/x86/mach-default
|
||||
+core-$(CONFIG_X86_RDC) += arch/x86/mach-rdc/
|
||||
+
|
||||
# Xen paravirtualization support
|
||||
core-$(CONFIG_XEN) += arch/x86/xen/
|
||||
|
||||
diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h
|
||||
--- linux-2.6.24/include/asm-x86/timex.h 2008-01-24 23:58:37.000000000 +0100
|
||||
+++ linux-2.6.24.new/include/asm-x86/timex.h 2008-02-11 18:25:43.000000000 +0100
|
||||
@@ -7,6 +7,8 @@
|
||||
|
||||
#ifdef CONFIG_X86_ELAN
|
||||
# define PIT_TICK_RATE 1189200 /* AMD Elan has different frequency! */
|
||||
+#elif defined(CONFIG_X86_RDC)
|
||||
+# define PIT_TICK_RATE 1041667 /* Underlying HZ for R8610 */
|
||||
#else
|
||||
# define PIT_TICK_RATE 1193182 /* Underlying HZ */
|
||||
#endif
|
18
target/linux/rdc/patches-2.6.24/006-pci_ids.patch
Normal file
18
target/linux/rdc/patches-2.6.24/006-pci_ids.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
|
||||
index 55f307f..4a1aa34 100644
|
||||
--- a/include/linux/pci_ids.h
|
||||
+++ b/include/linux/pci_ids.h
|
||||
@@ -2076,6 +2076,13 @@
|
||||
#define PCI_DEVICE_ID_HERC_WIN 0x5732
|
||||
#define PCI_DEVICE_ID_HERC_UNI 0x5832
|
||||
|
||||
+#define PCI_VENDOR_ID_RDC 0x17f3
|
||||
+#define PCI_DEVICE_ID_RDC_R6020 0x6020
|
||||
+#define PCI_DEVICE_ID_RDC_R6030 0x6030
|
||||
+#define PCI_DEVICE_ID_RDC_R6040 0x6040
|
||||
+#define PCI_DEVICE_ID_RDC_R6060 0x6060
|
||||
+#define PCI_DEVICE_ID_RDC_R6061 0x6061
|
||||
+
|
||||
#define PCI_VENDOR_ID_SITECOM 0x182d
|
||||
#define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069
|
||||
|
1044
target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
Normal file
1044
target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue