Add support for NAS100d apex builds, and deploy apex binaries
SVN-Revision: 14100
This commit is contained in:
parent
f30bf8cbd4
commit
30b2b911d2
3 changed files with 33 additions and 4 deletions
|
@ -9,21 +9,22 @@ include $(INCLUDE_DIR)/image.mk
|
|||
|
||||
define Image/Build/slug
|
||||
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
|
||||
-L $(KDIR)/apex-nslu2-armeb.bin \
|
||||
-L $(BIN_DIR)/apex-nslu2-armeb.bin \
|
||||
-k $(BIN_DIR)/openwrt-nslu2-zImage \
|
||||
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
|
||||
-p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
|
||||
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
|
||||
-F -L $(KDIR)/apex-nslu2-16mb-armeb.bin \
|
||||
-F -L $(BIN_DIR)/apex-nslu2-16mb-armeb.bin \
|
||||
-k $(BIN_DIR)/openwrt-nslu2-zImage \
|
||||
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
|
||||
-p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
mkdir -p $(BIN_DIR)
|
||||
$(MAKE) -C apex \
|
||||
BUILD_DIR="$(KDIR)" \
|
||||
TARGET="$(KDIR)" \
|
||||
TARGET="$(BIN_DIR)" \
|
||||
compile
|
||||
endef
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apex
|
||||
PKG_VERSION:=1.5.14
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -57,6 +57,16 @@ define Build/Compile
|
|||
ARCH=arm \
|
||||
all
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/apex.bin $(TARGET)/apex-fsg3-armeb.bin
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH=arm \
|
||||
slugos-nas100d-armeb_config
|
||||
$(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(PKG_BUILD_DIR)/.config
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
KBUILD_HAVE_NLS=no \
|
||||
ARCH=arm \
|
||||
all
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/apex.bin $(TARGET)/apex-nas100d-armeb.bin
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
--- apex-1.5.6/src/mach-ixp42x/slugos-nas100d-armeb_config 2007-06-02 10:06:45.000000000 +0930
|
||||
+++ apex-1.5.6/src/mach-ixp42x/slugos-nas100d-armeb_config~ 2007-06-03 02:22:18.000000000 +0930
|
||||
@@ -17,7 +17,7 @@
|
||||
#
|
||||
# General Setup
|
||||
#
|
||||
-CONFIG_TARGET_DESCRIPTION="SlugOS NAS100D/BE"
|
||||
+CONFIG_TARGET_DESCRIPTION="OpenWRT NAS100D"
|
||||
CONFIG_CROSS_COMPILE=""
|
||||
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
|
||||
# CONFIG_CC_OPTIMIZE_FOR_SPEED is not set
|
||||
@@ -143,5 +143,5 @@
|
||||
# Overrides
|
||||
#
|
||||
CONFIG_ENV_DEFAULT_CMDLINE_OVERRIDE=y
|
||||
-CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200"
|
||||
+CONFIG_ENV_DEFAULT_CMDLINE="root=/dev/mtdblock2 rootfstype=squashfs,jffs2 console=ttyS0,115200 init=/etc/preinit noinitrd"
|
||||
# CONFIG_ENV_DEFAULT_STARTUP_OVERRIDE is not set
|
Loading…
Reference in a new issue