mkelfimage: remove package, it is a host tool that has been unused for years
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
fb35ac857f
commit
2f8c355850
2 changed files with 0 additions and 46 deletions
|
@ -1,35 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=mkelfimage
|
|
||||||
PKG_VERSION:=2.7
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
|
|
||||||
PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/mkelfimage
|
|
||||||
SECTION:=base
|
|
||||||
CATEGORY:=Base system
|
|
||||||
TITLE:=mkelfimage
|
|
||||||
HIDDEN:=1
|
|
||||||
DEPENDS:=@i386
|
|
||||||
DEFAULT:=y if TARGET_x86
|
|
||||||
endef
|
|
||||||
|
|
||||||
CONFIGURE_VARS += AS="$(TARGET_CROSS)as"
|
|
||||||
MAKE_FLAGS += HOST_CC="$(HOSTCC)" DEFS="-I$(STAGING_DIR_HOST)/include"
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,mkelfimage))
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- mkelfimage-2.7.old//Makefile 2006-03-28 02:44:59.000000000 +0300
|
|
||||||
+++ mkelfimage-2.7/Makefile 2011-01-17 14:15:13.000000000 +0200
|
|
||||||
@@ -14,7 +14,7 @@
|
|
||||||
pkglibdir = $(libdir)/$(PACKAGE)
|
|
||||||
pkgincludedir = $(includedir)/$(PACKAGE)
|
|
||||||
|
|
||||||
-CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include
|
|
||||||
+CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include -fno-stack-protector
|
|
||||||
HOST_CPPFLAGS=$(CPPFLAGS)
|
|
||||||
I386_CPPFLAGS=$(CPPFLAGS) -I arch/i386/include
|
|
||||||
IA64_CPPFLAGS=$(CPPFLAGS) -I arch/ia64/include
|
|
Loading…
Reference in a new issue