iproute2: update to 4.16
Update to latest version of iproute2, refresh patches. See https://lkml.org/lkml/2018/4/2/349 for a full overview of the changes in 4.16. Build and tested on AR7xxx against musl Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
3aa28f4833
commit
2f1e329d7a
4 changed files with 7 additions and 17 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=4.15.0
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=4.16.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||
PKG_HASH:=48d4616a99d7b609b7b795c0ae8ec57099fb0271ed89253e8772c02327798355
|
||||
PKG_HASH:=0c5c24020fd7349fe25728c5edee9fb6a1bc8a38f08e23be5c57a6301e55ee0a
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=iptables
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -293,7 +293,7 @@ check_selinux()
|
||||
@@ -281,7 +281,7 @@ check_selinux()
|
||||
|
||||
check_mnl()
|
||||
{
|
||||
|
|
|
@ -89,7 +89,7 @@
|
|||
{ "help", do_help },
|
||||
--- a/lib/utils.c
|
||||
+++ b/lib/utils.c
|
||||
@@ -885,6 +885,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||
@@ -983,6 +983,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||
return inet_ntop(af, addr, buf, buflen);
|
||||
case AF_MPLS:
|
||||
return mpls_ntop(af, addr, buf, buflen);
|
||||
|
@ -97,14 +97,14 @@
|
|||
case AF_IPX:
|
||||
return ipx_ntop(af, addr, buf, buflen);
|
||||
case AF_DECnet:
|
||||
@@ -894,6 +895,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||
@@ -992,6 +993,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||
memcpy(dna.a_addr, addr, 2);
|
||||
return dnet_ntop(af, &dna, buf, buflen);
|
||||
}
|
||||
+#endif
|
||||
case AF_PACKET:
|
||||
return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
|
||||
default:
|
||||
case AF_BRIDGE:
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -3,6 +3,10 @@ include ../config.mk
|
||||
|
|
|
@ -1,5 +1,3 @@
|
|||
diff --git a/include/uapi/linux/pkt_sched.h b/include/uapi/linux/pkt_sched.h
|
||||
index 37b5096a..66da5df9 100644
|
||||
--- a/include/uapi/linux/pkt_sched.h
|
||||
+++ b/include/uapi/linux/pkt_sched.h
|
||||
@@ -934,4 +934,75 @@ enum {
|
||||
|
@ -78,9 +76,6 @@ index 37b5096a..66da5df9 100644
|
|||
+};
|
||||
+
|
||||
#endif
|
||||
diff --git a/man/man8/tc-cake.8 b/man/man8/tc-cake.8
|
||||
new file mode 100644
|
||||
index 00000000..ff77db8f
|
||||
--- /dev/null
|
||||
+++ b/man/man8/tc-cake.8
|
||||
@@ -0,0 +1,678 @@
|
||||
|
@ -762,8 +757,6 @@ index 00000000..ff77db8f
|
|||
+
|
||||
+This manual page was written by Loganaden Velvindron. Please report corrections
|
||||
+to the Linux Networking mailing list <netdev@vger.kernel.org>.
|
||||
diff --git a/tc/Makefile b/tc/Makefile
|
||||
index 3716dd6a..69f50a6b 100644
|
||||
--- a/tc/Makefile
|
||||
+++ b/tc/Makefile
|
||||
@@ -64,6 +64,7 @@ TCMODULES += em_meta.o
|
||||
|
@ -774,9 +767,6 @@ index 3716dd6a..69f50a6b 100644
|
|||
TCMODULES += q_fq.o
|
||||
TCMODULES += q_pie.o
|
||||
TCMODULES += q_hhf.o
|
||||
diff --git a/tc/q_cake.c b/tc/q_cake.c
|
||||
new file mode 100644
|
||||
index 00000000..44cadb63
|
||||
--- /dev/null
|
||||
+++ b/tc/q_cake.c
|
||||
@@ -0,0 +1,770 @@
|
||||
|
|
Loading…
Reference in a new issue