add missing binutils patches
SVN-Revision: 343
This commit is contained in:
parent
4e08bed042
commit
2d989f9343
2 changed files with 44 additions and 0 deletions
32
openwrt/toolchain/binutils/all/210-cflags.patch
Normal file
32
openwrt/toolchain/binutils/all/210-cflags.patch
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
diff -urN binutils-2.14.90.0.6/bfd/doc/Makefile.am binutils-2.14.90.0.6.new/bfd/doc/Makefile.am
|
||||||
|
--- binutils-2.14.90.0.6/bfd/doc/Makefile.am 2003-07-23 10:08:09.000000000 -0500
|
||||||
|
+++ binutils-2.14.90.0.6.new/bfd/doc/Makefile.am 2004-03-01 16:05:16.000000000 -0600
|
||||||
|
@@ -55,10 +55,10 @@
|
||||||
|
MKDOC = chew$(EXEEXT_FOR_BUILD)
|
||||||
|
|
||||||
|
$(MKDOC): chew.o
|
||||||
|
- $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS) $(LOADLIBES) $(LDFLAGS)
|
||||||
|
+ $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS_FOR_BUILD) $(LOADLIBES) $(LDFLAGS)
|
||||||
|
|
||||||
|
chew.o: chew.c
|
||||||
|
- $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS) $(srcdir)/chew.c
|
||||||
|
+ $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS_FOR_BUILD) $(srcdir)/chew.c
|
||||||
|
|
||||||
|
protos: libbfd.h libcoff.h bfd.h
|
||||||
|
|
||||||
|
diff -urN binutils-2.14.90.0.6/bfd/doc/Makefile.in binutils-2.14.90.0.6.new/bfd/doc/Makefile.in
|
||||||
|
--- binutils-2.14.90.0.6/bfd/doc/Makefile.in 2003-07-23 10:08:09.000000000 -0500
|
||||||
|
+++ binutils-2.14.90.0.6.new/bfd/doc/Makefile.in 2004-03-01 16:05:03.000000000 -0600
|
||||||
|
@@ -469,10 +469,10 @@
|
||||||
|
|
||||||
|
|
||||||
|
$(MKDOC): chew.o
|
||||||
|
- $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS) $(LOADLIBES) $(LDFLAGS)
|
||||||
|
+ $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS_FOR_BUILD) $(LOADLIBES) $(LDFLAGS)
|
||||||
|
|
||||||
|
chew.o: chew.c
|
||||||
|
- $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS) $(srcdir)/chew.c
|
||||||
|
+ $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS_FOR_BUILD) $(srcdir)/chew.c
|
||||||
|
|
||||||
|
protos: libbfd.h libcoff.h bfd.h
|
||||||
|
|
|
@ -0,0 +1,12 @@
|
||||||
|
diff -urN binutils-2.14.90.0.8.test/bfd/elf32-mips.c binutils-2.14.90.0.8/bfd/elf32-mips.c
|
||||||
|
--- binutils-2.14.90.0.8.test/bfd/elf32-mips.c 2004-01-14 22:07:43.000000000 +0100
|
||||||
|
+++ binutils-2.14.90.0.8/bfd/elf32-mips.c 2005-03-03 23:44:00.000000000 +0100
|
||||||
|
@@ -1611,7 +1611,7 @@
|
||||||
|
|
||||||
|
/* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses
|
||||||
|
page sizes of up to that limit, so we need to respect it. */
|
||||||
|
-#define ELF_MAXPAGESIZE 0x10000
|
||||||
|
+#define ELF_MAXPAGESIZE 0x1000
|
||||||
|
#define elf32_bed elf32_tradbed
|
||||||
|
|
||||||
|
/* Include the target file again for this target. */
|
Loading…
Reference in a new issue