kernel: update linux 3.8 to 3.8.1
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35862
This commit is contained in:
parent
da79a4c698
commit
26fbc15a86
12 changed files with 23 additions and 24 deletions
|
@ -11,8 +11,8 @@ endif
|
||||||
ifeq ($(LINUX_VERSION),3.7.10)
|
ifeq ($(LINUX_VERSION),3.7.10)
|
||||||
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.8)
|
ifeq ($(LINUX_VERSION),3.8.1)
|
||||||
LINUX_KERNEL_MD5SUM:=1c738edfc54e7c65faeb90c436104e2f
|
LINUX_KERNEL_MD5SUM:=093b172f907d5455a6746418ad18f5bc
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
|
|
@ -242,7 +242,7 @@
|
||||||
np->rxopt.bits.osrcrt)) ||
|
np->rxopt.bits.osrcrt)) ||
|
||||||
--- a/net/ipv6/route.c
|
--- a/net/ipv6/route.c
|
||||||
+++ b/net/ipv6/route.c
|
+++ b/net/ipv6/route.c
|
||||||
@@ -994,7 +994,7 @@ void ip6_route_input(struct sk_buff *skb
|
@@ -995,7 +995,7 @@ void ip6_route_input(struct sk_buff *skb
|
||||||
.flowi6_iif = skb->dev->ifindex,
|
.flowi6_iif = skb->dev->ifindex,
|
||||||
.daddr = iph->daddr,
|
.daddr = iph->daddr,
|
||||||
.saddr = iph->saddr,
|
.saddr = iph->saddr,
|
||||||
|
@ -467,7 +467,7 @@
|
||||||
#endif /* _LINUX_TYPES_H */
|
#endif /* _LINUX_TYPES_H */
|
||||||
--- a/net/ipv4/af_inet.c
|
--- a/net/ipv4/af_inet.c
|
||||||
+++ b/net/ipv4/af_inet.c
|
+++ b/net/ipv4/af_inet.c
|
||||||
@@ -1391,8 +1391,8 @@ static struct sk_buff **inet_gro_receive
|
@@ -1396,8 +1396,8 @@ static struct sk_buff **inet_gro_receive
|
||||||
if (unlikely(ip_fast_csum((u8 *)iph, 5)))
|
if (unlikely(ip_fast_csum((u8 *)iph, 5)))
|
||||||
goto out_unlock;
|
goto out_unlock;
|
||||||
|
|
||||||
|
|
|
@ -6,7 +6,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||||
|
|
||||||
--- a/arch/mips/kernel/cevt-r4k.c
|
--- a/arch/mips/kernel/cevt-r4k.c
|
||||||
+++ b/arch/mips/kernel/cevt-r4k.c
|
+++ b/arch/mips/kernel/cevt-r4k.c
|
||||||
@@ -168,20 +168,23 @@ int __cpuinit r4k_clockevent_init(void)
|
@@ -173,20 +173,23 @@ int __cpuinit r4k_clockevent_init(void)
|
||||||
struct clock_event_device *cd;
|
struct clock_event_device *cd;
|
||||||
unsigned int irq;
|
unsigned int irq;
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -120,6 +120,19 @@ config BCM63XX
|
@@ -135,6 +135,19 @@ config BCM63XX
|
||||||
help
|
help
|
||||||
Support for BCM63XX based boards
|
Support for BCM63XX based boards
|
||||||
|
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
config MIPS_COBALT
|
config MIPS_COBALT
|
||||||
bool "Cobalt Server"
|
bool "Cobalt Server"
|
||||||
select CEVT_R4K
|
select CEVT_R4K
|
||||||
@@ -813,6 +826,7 @@ config NLM_XLP_BOARD
|
@@ -836,6 +849,7 @@ config NLM_XLP_BOARD
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
|
|
|
@ -58,7 +58,7 @@
|
||||||
obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
|
obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -130,6 +130,7 @@ config ATHEROS_AR231X
|
@@ -145,6 +145,7 @@ config ATHEROS_AR231X
|
||||||
select SYS_SUPPORTS_BIG_ENDIAN
|
select SYS_SUPPORTS_BIG_ENDIAN
|
||||||
select SYS_SUPPORTS_32BIT_KERNEL
|
select SYS_SUPPORTS_32BIT_KERNEL
|
||||||
select ARCH_REQUIRE_GPIOLIB
|
select ARCH_REQUIRE_GPIOLIB
|
||||||
|
|
|
@ -202,7 +202,7 @@
|
||||||
+module_exit(exit_ar2315_wdt);
|
+module_exit(exit_ar2315_wdt);
|
||||||
--- a/drivers/watchdog/Kconfig
|
--- a/drivers/watchdog/Kconfig
|
||||||
+++ b/drivers/watchdog/Kconfig
|
+++ b/drivers/watchdog/Kconfig
|
||||||
@@ -1064,6 +1064,12 @@ config LANTIQ_WDT
|
@@ -1076,6 +1076,12 @@ config LANTIQ_WDT
|
||||||
help
|
help
|
||||||
Hardware driver for the Lantiq SoC Watchdog Timer.
|
Hardware driver for the Lantiq SoC Watchdog Timer.
|
||||||
|
|
||||||
|
|
|
@ -17,7 +17,7 @@
|
||||||
int nrparts = 0;
|
int nrparts = 0;
|
||||||
struct fis_image_desc *buf;
|
struct fis_image_desc *buf;
|
||||||
struct mtd_partition *parts;
|
struct mtd_partition *parts;
|
||||||
@@ -227,14 +230,14 @@ static int parse_redboot_partitions(stru
|
@@ -225,14 +228,14 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
@ -34,7 +34,7 @@
|
||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
if (nulllen > 0) {
|
if (nulllen > 0) {
|
||||||
strcpy(nullname, nullstring);
|
strcpy(nullname, nullstring);
|
||||||
@@ -253,6 +256,8 @@ static int parse_redboot_partitions(stru
|
@@ -251,6 +254,8 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
for ( ; i<nrparts; i++) {
|
for ( ; i<nrparts; i++) {
|
||||||
|
@ -43,7 +43,7 @@
|
||||||
parts[i].size = fl->img->size;
|
parts[i].size = fl->img->size;
|
||||||
parts[i].offset = fl->img->flash_base;
|
parts[i].offset = fl->img->flash_base;
|
||||||
parts[i].name = names;
|
parts[i].name = names;
|
||||||
@@ -286,6 +291,14 @@ static int parse_redboot_partitions(stru
|
@@ -284,6 +289,14 @@ static int parse_redboot_partitions(stru
|
||||||
fl = fl->next;
|
fl = fl->next;
|
||||||
kfree(tmp_fl);
|
kfree(tmp_fl);
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/mtd/redboot.c
|
--- a/drivers/mtd/redboot.c
|
||||||
+++ b/drivers/mtd/redboot.c
|
+++ b/drivers/mtd/redboot.c
|
||||||
@@ -79,6 +79,11 @@ static int parse_redboot_partitions(stru
|
@@ -79,12 +79,18 @@ static int parse_redboot_partitions(stru
|
||||||
static char nullstring[] = "unallocated";
|
static char nullstring[] = "unallocated";
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -11,8 +11,7 @@
|
||||||
+ restart:
|
+ restart:
|
||||||
if ( directory < 0 ) {
|
if ( directory < 0 ) {
|
||||||
offset = master->size + directory * master->erasesize;
|
offset = master->size + directory * master->erasesize;
|
||||||
while (mtd_can_have_bb(master) &&
|
while (mtd_block_isbad(master, offset)) {
|
||||||
@@ -86,6 +91,7 @@ static int parse_redboot_partitions(stru
|
|
||||||
if (!offset) {
|
if (!offset) {
|
||||||
nogood:
|
nogood:
|
||||||
printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
|
printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
|
||||||
|
@ -20,7 +19,7 @@
|
||||||
return -EIO;
|
return -EIO;
|
||||||
}
|
}
|
||||||
offset -= master->erasesize;
|
offset -= master->erasesize;
|
||||||
@@ -99,10 +105,6 @@ static int parse_redboot_partitions(stru
|
@@ -97,10 +103,6 @@ static int parse_redboot_partitions(stru
|
||||||
goto nogood;
|
goto nogood;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -31,7 +30,7 @@
|
||||||
|
|
||||||
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
||||||
master->name, offset);
|
master->name, offset);
|
||||||
@@ -175,6 +177,11 @@ static int parse_redboot_partitions(stru
|
@@ -173,6 +175,11 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
if (i == numslots) {
|
if (i == numslots) {
|
||||||
/* Didn't find it */
|
/* Didn't find it */
|
||||||
|
|
|
@ -31,7 +31,7 @@
|
||||||
unsigned long offset;
|
unsigned long offset;
|
||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
static char nullstring[] = "unallocated";
|
static char nullstring[] = "unallocated";
|
||||||
@@ -188,7 +205,10 @@ static int parse_redboot_partitions(stru
|
@@ -186,7 +203,10 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -43,7 +43,7 @@
|
||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
if (buf[i].name[0] == 0xff) {
|
if (buf[i].name[0] == 0xff) {
|
||||||
@@ -263,12 +283,13 @@ static int parse_redboot_partitions(stru
|
@@ -261,12 +281,13 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
for ( ; i<nrparts; i++) {
|
for ( ; i<nrparts; i++) {
|
||||||
|
@ -59,7 +59,7 @@
|
||||||
strcpy(names, fl->img->name);
|
strcpy(names, fl->img->name);
|
||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
|
||||||
if (!memcmp(names, "RedBoot", 8) ||
|
if (!memcmp(names, "RedBoot", 8) ||
|
||||||
@@ -298,7 +319,9 @@ static int parse_redboot_partitions(stru
|
@@ -296,7 +317,9 @@ static int parse_redboot_partitions(stru
|
||||||
fl = fl->next;
|
fl = fl->next;
|
||||||
kfree(tmp_fl);
|
kfree(tmp_fl);
|
||||||
}
|
}
|
||||||
|
|
|
@ -319,7 +319,7 @@
|
||||||
goto out;
|
goto out;
|
||||||
--- a/fs/namespace.c
|
--- a/fs/namespace.c
|
||||||
+++ b/fs/namespace.c
|
+++ b/fs/namespace.c
|
||||||
@@ -1410,6 +1410,24 @@ void drop_collected_mounts(struct vfsmou
|
@@ -1417,6 +1417,24 @@ void drop_collected_mounts(struct vfsmou
|
||||||
release_mounts(&umount_list);
|
release_mounts(&umount_list);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/mm/shmem.c
|
--- a/mm/shmem.c
|
||||||
+++ b/mm/shmem.c
|
+++ b/mm/shmem.c
|
||||||
@@ -2865,6 +2865,15 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
@@ -2871,6 +2871,15 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
||||||
|
|
||||||
/* common code */
|
/* common code */
|
||||||
|
|
||||||
|
@ -16,7 +16,7 @@
|
||||||
/**
|
/**
|
||||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||||
@@ -2941,11 +2950,8 @@ int shmem_zero_setup(struct vm_area_stru
|
@@ -2947,11 +2956,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||||
file = shmem_file_setup("dev/zero", size, vma->vm_flags);
|
file = shmem_file_setup("dev/zero", size, vma->vm_flags);
|
||||||
if (IS_ERR(file))
|
if (IS_ERR(file))
|
||||||
return PTR_ERR(file);
|
return PTR_ERR(file);
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
|
||||||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8
|
LINUX_VERSION:=3.8.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue