kernel: update linux 3.6 to 3.6.9
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34578
This commit is contained in:
parent
47f9b2a110
commit
2581173660
10 changed files with 19 additions and 21 deletions
|
@ -5,8 +5,8 @@ LINUX_RELEASE?=1
|
|||
ifeq ($(LINUX_VERSION),3.3.8)
|
||||
LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.6.8)
|
||||
LINUX_KERNEL_MD5SUM:=e3405cc8f9e4f18c516e55a8eb625803
|
||||
ifeq ($(LINUX_VERSION),3.6.9)
|
||||
LINUX_KERNEL_MD5SUM:=f77bac0a8f499f221d13a69317145610
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -53,11 +53,9 @@ Date: Wed Nov 21 10:27:19 2012 +0000
|
|||
Cc: stable@kernel.org [3.5+]
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
|
||||
diff --git a/drivers/net/ethernet/realtek/8139cp.c b/drivers/net/ethernet/realtek/8139cp.c
|
||||
index 1c81825..6cb96b4 100644
|
||||
--- a/drivers/net/ethernet/realtek/8139cp.c
|
||||
+++ b/drivers/net/ethernet/realtek/8139cp.c
|
||||
@@ -648,6 +648,7 @@ static void cp_tx (struct cp_private *cp)
|
||||
@@ -648,6 +648,7 @@ static void cp_tx (struct cp_private *cp
|
||||
{
|
||||
unsigned tx_head = cp->tx_head;
|
||||
unsigned tx_tail = cp->tx_tail;
|
||||
|
@ -65,7 +63,7 @@ index 1c81825..6cb96b4 100644
|
|||
|
||||
while (tx_tail != tx_head) {
|
||||
struct cp_desc *txd = cp->tx_ring + tx_tail;
|
||||
@@ -666,6 +667,9 @@ static void cp_tx (struct cp_private *cp)
|
||||
@@ -666,6 +667,9 @@ static void cp_tx (struct cp_private *cp
|
||||
le32_to_cpu(txd->opts1) & 0xffff,
|
||||
PCI_DMA_TODEVICE);
|
||||
|
||||
|
@ -75,7 +73,7 @@ index 1c81825..6cb96b4 100644
|
|||
if (status & LastFrag) {
|
||||
if (status & (TxError | TxFIFOUnder)) {
|
||||
netif_dbg(cp, tx_err, cp->dev,
|
||||
@@ -697,6 +701,7 @@ static void cp_tx (struct cp_private *cp)
|
||||
@@ -697,6 +701,7 @@ static void cp_tx (struct cp_private *cp
|
||||
|
||||
cp->tx_tail = tx_tail;
|
||||
|
||||
|
@ -83,7 +81,7 @@ index 1c81825..6cb96b4 100644
|
|||
if (TX_BUFFS_AVAIL(cp) > (MAX_SKB_FRAGS + 1))
|
||||
netif_wake_queue(cp->dev);
|
||||
}
|
||||
@@ -843,6 +848,8 @@ static netdev_tx_t cp_start_xmit (struct sk_buff *skb,
|
||||
@@ -843,6 +848,8 @@ static netdev_tx_t cp_start_xmit (struct
|
||||
wmb();
|
||||
}
|
||||
cp->tx_head = entry;
|
||||
|
@ -92,7 +90,7 @@ index 1c81825..6cb96b4 100644
|
|||
netif_dbg(cp, tx_queued, cp->dev, "tx queued, slot %d, skblen %d\n",
|
||||
entry, skb->len);
|
||||
if (TX_BUFFS_AVAIL(cp) <= (MAX_SKB_FRAGS + 1))
|
||||
@@ -937,6 +944,8 @@ static void cp_stop_hw (struct cp_private *cp)
|
||||
@@ -937,6 +944,8 @@ static void cp_stop_hw (struct cp_privat
|
||||
|
||||
cp->rx_tail = 0;
|
||||
cp->tx_head = cp->tx_tail = 0;
|
||||
|
@ -101,7 +99,7 @@ index 1c81825..6cb96b4 100644
|
|||
}
|
||||
|
||||
static void cp_reset_hw (struct cp_private *cp)
|
||||
@@ -957,8 +966,38 @@ static void cp_reset_hw (struct cp_private *cp)
|
||||
@@ -957,8 +966,38 @@ static void cp_reset_hw (struct cp_priva
|
||||
|
||||
static inline void cp_start_hw (struct cp_private *cp)
|
||||
{
|
||||
|
@ -140,7 +138,7 @@ index 1c81825..6cb96b4 100644
|
|||
}
|
||||
|
||||
static void cp_enable_irq(struct cp_private *cp)
|
||||
@@ -969,7 +1008,6 @@ static void cp_enable_irq(struct cp_private *cp)
|
||||
@@ -969,7 +1008,6 @@ static void cp_enable_irq(struct cp_priv
|
||||
static void cp_init_hw (struct cp_private *cp)
|
||||
{
|
||||
struct net_device *dev = cp->dev;
|
||||
|
@ -148,7 +146,7 @@ index 1c81825..6cb96b4 100644
|
|||
|
||||
cp_reset_hw(cp);
|
||||
|
||||
@@ -979,17 +1017,6 @@ static void cp_init_hw (struct cp_private *cp)
|
||||
@@ -979,17 +1017,6 @@ static void cp_init_hw (struct cp_privat
|
||||
cpw32_f (MAC0 + 0, le32_to_cpu (*(__le32 *) (dev->dev_addr + 0)));
|
||||
cpw32_f (MAC0 + 4, le32_to_cpu (*(__le32 *) (dev->dev_addr + 4)));
|
||||
|
||||
|
@ -166,7 +164,7 @@ index 1c81825..6cb96b4 100644
|
|||
cp_start_hw(cp);
|
||||
cpw8(TxThresh, 0x06); /* XXX convert magic num to a constant */
|
||||
|
||||
@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_device *dev)
|
||||
@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_dev
|
||||
cp_clean_rings(cp);
|
||||
rc = cp_init_rings(cp);
|
||||
cp_start_hw(cp);
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=danube ar9 vr9 falcon svip_be
|
|||
LINUX_VERSION:=3.3.8
|
||||
|
||||
#SUBTARGETS=xway ase
|
||||
#LINUX_VERSION:=3.6.8
|
||||
#LINUX_VERSION:=3.6.9
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
|||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
||||
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-cpu-msr \
|
||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||
hwclock wpad flashrom tc
|
||||
LINUX_VERSION:=3.6.8
|
||||
LINUX_VERSION:=3.6.9
|
||||
CS5535_MASK:=0x0E000048
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
Loading…
Reference in a new issue