gengetopt: fix parallel build issues (#18442)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43440
This commit is contained in:
parent
47f09fd345
commit
2311cfeed4
3 changed files with 14 additions and 0 deletions
|
@ -73,6 +73,7 @@ $(curdir)/padjffs2/compile := $(curdir)/findutils/install
|
|||
$(curdir)/cloog/compile := $(curdir)/ppl/install
|
||||
$(curdir)/bc/compile := $(curdir)/bison/install
|
||||
$(curdir)/findutils/compile := $(curdir)/bison/install
|
||||
$(curdir)/gengetopt/compile := $(curdir)/automake/install
|
||||
|
||||
ifneq ($(CONFIG_CCACHE),)
|
||||
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
|
||||
|
|
|
@ -13,6 +13,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
|
||||
|
||||
HOST_FIXUP := autoreconf
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
|
11
tools/gengetopt/patches/100-dependency_fix.patch
Normal file
11
tools/gengetopt/patches/100-dependency_fix.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -51,7 +51,7 @@ libgengetopt_la_LIBADD = $(top_builddir)
|
||||
@LTLIBOBJS@ \
|
||||
skels/libgen.la
|
||||
|
||||
-LDADD = $(top_builddir)/src/libgengetopt.la
|
||||
+LDADD = libgengetopt.la
|
||||
|
||||
EXTRA_DIST = parser.h argsdef.h gengetopt.h ggos.h gm.h gnugetopt.h \
|
||||
cmdline.c cmdline.h \
|
Loading…
Reference in a new issue