ath9k: compile out the ath9k rate control
SVN-Revision: 23163
This commit is contained in:
parent
5df80ba3a7
commit
1cbea05927
2 changed files with 11 additions and 13 deletions
|
@ -24,7 +24,6 @@ PKG_BUILD_PARALLEL:=1
|
|||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_PACKAGE_kmod-mac80211 \
|
||||
CONFIG_PACKAGE_MAC80211_DEBUGFS \
|
||||
CONFIG_PACKAGE_ATH9K_USE_MINSTREL \
|
||||
CONFIG_PACKAGE_ATH_DEBUG \
|
||||
CONFIG_ATH_USER_REGD \
|
||||
|
||||
|
@ -446,17 +445,6 @@ This module adds support for wireless adapters based on
|
|||
Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.
|
||||
endef
|
||||
|
||||
define KernelPackage/ath9k/config
|
||||
menu "Configuration"
|
||||
depends PACKAGE_kmod-ath9k
|
||||
|
||||
config PACKAGE_ATH9K_USE_MINSTREL
|
||||
bool "use the new minstrel_ht rate control for ath9k"
|
||||
default y
|
||||
|
||||
endmenu
|
||||
endef
|
||||
|
||||
define KernelPackage/carl9170
|
||||
$(call KernelPackage/mac80211/Default)
|
||||
TITLE:=Driver for Atheros AR9170 USB sticks
|
||||
|
@ -837,7 +825,6 @@ BUILDFLAGS:= \
|
|||
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
|
||||
-DCONFIG_MAC80211_RC_MINSTREL_HT \
|
||||
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1) \
|
||||
$(if $(CONFIG_PACKAGE_ATH9K_USE_MINSTREL),-DATH9K_USE_MINSTREL) \
|
||||
$(if $(CONFIG_PACKAGE_RT2X00_LIB_DEBUGFS),-DCONFIG_RT2X00_LIB_DEBUGFS) \
|
||||
$(if $(CONFIG_PACKAGE_RT2X00_DEBUG),-DCONFIG_RT2X00_DEBUG) \
|
||||
$(if $(NEED_RT2X00_LIB_HT),-DCONFIG_RT2X00_LIB_HT) \
|
||||
|
|
11
package/mac80211/patches/017-remove_ath9k_rc.patch
Normal file
11
package/mac80211/patches/017-remove_ath9k_rc.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -204,7 +204,7 @@ CONFIG_ATH9K_COMMON=m
|
||||
# as default once we get minstrel properly tested and blessed by
|
||||
# our systems engineering team. CCK rates also need to be used
|
||||
# for long range considerations.
|
||||
-CONFIG_ATH9K_RATE_CONTROL=y
|
||||
+# CONFIG_ATH9K_RATE_CONTROL=y
|
||||
|
||||
|
||||
CONFIG_COMPAT_IWLWIFI=m
|
Loading…
Reference in a new issue