au1000: fix 3.18 and set it as default
Thanks to Bruno Randolf for testing and Manuel Lauss for providing a fix. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44487
This commit is contained in:
parent
f9aa2ec7f6
commit
1a1d69da08
2 changed files with 12 additions and 1 deletions
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
|
|||
SUBTARGETS=au1500 au1550
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
KERNEL_PATCHVER:=3.14
|
||||
KERNEL_PATCHVER:=3.18
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
|
11
target/linux/au1000/patches/005-fix-cpu-clk.patch
Normal file
11
target/linux/au1000/patches/005-fix-cpu-clk.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/arch/mips/alchemy/common/clock.c
|
||||
+++ b/arch/mips/alchemy/common/clock.c
|
||||
@@ -128,6 +128,8 @@
|
||||
t = 396000000;
|
||||
else {
|
||||
t = alchemy_rdsys(AU1000_SYS_CPUPLL) & 0x7f;
|
||||
+ if (alchemy_get_cputype() != ALCHEMY_CPU_AU1300)
|
||||
+ t &= 0x3f;
|
||||
t *= parent_rate;
|
||||
}
|
||||
|
Loading…
Reference in a new issue