curl: update to version 7.52.1
This fixes the folowing security problems: CVE-2016-9586: printf floating point buffer overflow CVE-2016-9952: Win CE schannel cert wildcard matches too much CVE-2016-9953: Win CE schannel cert name out of buffer read CVE-2016-9594: unititialized random Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
3e2c60e476
commit
1436e15488
2 changed files with 4 additions and 4 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=7.51.0
|
PKG_VERSION:=7.52.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
|
||||||
ftp://ftp.planetmirror.com/pub/curl/ \
|
ftp://ftp.planetmirror.com/pub/curl/ \
|
||||||
http://www.mirrormonster.com/curl/download/ \
|
http://www.mirrormonster.com/curl/download/ \
|
||||||
http://curl.mirrors.cyberservers.net/download/
|
http://curl.mirrors.cyberservers.net/download/
|
||||||
PKG_HASH:=7f8240048907e5030f67be0a6129bc4b333783b9cca1391026d700835a788dde
|
PKG_HASH:=d16185a767cb2c1ba3d5b9096ec54e5ec198b213f45864a38b3bda4bbf87389b
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/vtls/polarssl.c
|
--- a/lib/vtls/polarssl.c
|
||||||
+++ b/lib/vtls/polarssl.c
|
+++ b/lib/vtls/polarssl.c
|
||||||
@@ -646,7 +646,7 @@ void Curl_polarssl_session_free(void *pt
|
@@ -657,7 +657,7 @@ void Curl_polarssl_session_free(void *pt
|
||||||
|
|
||||||
size_t Curl_polarssl_version(char *buffer, size_t size)
|
size_t Curl_polarssl_version(char *buffer, size_t size)
|
||||||
{
|
{
|
||||||
|
@ -11,7 +11,7 @@
|
||||||
version>>24, (version>>16)&0xff, (version>>8)&0xff);
|
version>>24, (version>>16)&0xff, (version>>8)&0xff);
|
||||||
--- a/lib/vtls/mbedtls.c
|
--- a/lib/vtls/mbedtls.c
|
||||||
+++ b/lib/vtls/mbedtls.c
|
+++ b/lib/vtls/mbedtls.c
|
||||||
@@ -712,7 +712,7 @@ void Curl_mbedtls_session_free(void *ptr
|
@@ -724,7 +724,7 @@ void Curl_mbedtls_session_free(void *ptr
|
||||||
|
|
||||||
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
||||||
{
|
{
|
||||||
|
|
Loading…
Reference in a new issue