refresh 2.6.24 patches

SVN-Revision: 14452
This commit is contained in:
Gabor Juhos 2009-02-08 19:18:19 +00:00
parent 27dee35f99
commit 1200d62f66
10 changed files with 59 additions and 86 deletions

View file

@ -1,7 +1,6 @@
diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig --- a/arch/mips/Kconfig
--- linux-2.6.24.7/arch/mips/Kconfig 2008-05-07 01:22:34.000000000 +0200 +++ b/arch/mips/Kconfig
+++ linux-2.6.24.7.new/arch/mips/Kconfig 2008-07-15 15:29:51.000000000 +0200 @@ -687,6 +687,23 @@ config WR_PPMC
@@ -687,6 +687,23 @@
This enables support for the Wind River MIPS32 4KC PPMC evaluation This enables support for the Wind River MIPS32 4KC PPMC evaluation
board, which is based on GT64120 bridge chip. board, which is based on GT64120 bridge chip.
@ -25,7 +24,7 @@ diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig
endchoice endchoice
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
@@ -967,6 +982,7 @@ @@ -967,6 +984,7 @@ config MIPS_L1_CACHE_SHIFT
default "4" if MACH_DECSTATION default "4" if MACH_DECSTATION
default "7" if SGI_IP27 || SNI_RM default "7" if SGI_IP27 || SNI_RM
default "4" if PMC_MSP4200_EVAL default "4" if PMC_MSP4200_EVAL
@ -33,10 +32,9 @@ diff -urN linux-2.6.24.7/arch/mips/Kconfig linux-2.6.24.7.new/arch/mips/Kconfig
default "5" default "5"
config HAVE_STD_PC_SERIAL_PORT config HAVE_STD_PC_SERIAL_PORT
diff -urN linux-2.6.24.7/arch/mips/Makefile linux-2.6.24.7.new/arch/mips/Makefile --- a/arch/mips/Makefile
--- linux-2.6.24.7/arch/mips/Makefile 2008-07-15 15:27:55.000000000 +0200 +++ b/arch/mips/Makefile
+++ linux-2.6.24.7.new/arch/mips/Makefile 2008-07-15 15:30:21.000000000 +0200 @@ -297,6 +297,13 @@ load-$(CONFIG_LEMOTE_FULONG) +=0xfffffff
@@ -297,6 +297,13 @@
cflags-$(CONFIG_LEMOTE_FULONG) += -Iinclude/asm-mips/mach-lemote cflags-$(CONFIG_LEMOTE_FULONG) += -Iinclude/asm-mips/mach-lemote
# #
@ -50,18 +48,16 @@ diff -urN linux-2.6.24.7/arch/mips/Makefile linux-2.6.24.7.new/arch/mips/Makefil
# For all MIPS, Inc. eval boards # For all MIPS, Inc. eval boards
# #
core-$(CONFIG_MIPS_BOARDS_GEN) += arch/mips/mips-boards/generic/ core-$(CONFIG_MIPS_BOARDS_GEN) += arch/mips/mips-boards/generic/
diff -urN linux-2.6.24.7/arch/mips/pci/Makefile linux-2.6.24.7.new/arch/mips/pci/Makefile --- a/arch/mips/pci/Makefile
--- linux-2.6.24.7/arch/mips/pci/Makefile 2008-05-07 01:22:34.000000000 +0200 +++ b/arch/mips/pci/Makefile
+++ linux-2.6.24.7.new/arch/mips/pci/Makefile 2008-07-15 15:30:46.000000000 +0200 @@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
@@ -48,3 +48,4 @@
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_MIKROTIK_RB500) += pci-rc32434.o ops-rc32434.o fixup-rb500.o +obj-$(CONFIG_MIKROTIK_RB500) += pci-rc32434.o ops-rc32434.o fixup-rb500.o
diff -urN linux-2.6.24.7/drivers/pci/Makefile linux-2.6.24.7.new/drivers/pci/Makefile --- a/drivers/pci/Makefile
--- linux-2.6.24.7/drivers/pci/Makefile 2008-05-07 01:22:34.000000000 +0200 +++ b/drivers/pci/Makefile
+++ linux-2.6.24.7.new/drivers/pci/Makefile 2008-07-15 15:31:20.000000000 +0200 @@ -35,6 +35,7 @@ obj-$(CONFIG_PPC32) += setup-irq.o
@@ -35,6 +35,7 @@
obj-$(CONFIG_PPC64) += setup-bus.o obj-$(CONFIG_PPC64) += setup-bus.o
obj-$(CONFIG_MIPS) += setup-bus.o setup-irq.o obj-$(CONFIG_MIPS) += setup-bus.o setup-irq.o
obj-$(CONFIG_X86_VISWS) += setup-irq.o obj-$(CONFIG_X86_VISWS) += setup-irq.o
@ -69,9 +65,8 @@ diff -urN linux-2.6.24.7/drivers/pci/Makefile linux-2.6.24.7.new/drivers/pci/Mak
# #
# ACPI Related PCI FW Functions # ACPI Related PCI FW Functions
diff -urN linux-2.6.24.7/include/asm-mips/bootinfo.h linux-2.6.24.7.new/include/asm-mips/bootinfo.h --- a/include/asm-mips/bootinfo.h
--- linux-2.6.24.7/include/asm-mips/bootinfo.h 2008-05-07 01:22:34.000000000 +0200 +++ b/include/asm-mips/bootinfo.h
+++ linux-2.6.24.7.new/include/asm-mips/bootinfo.h 2008-07-15 15:32:06.000000000 +0200
@@ -198,6 +198,14 @@ @@ -198,6 +198,14 @@
#define MACH_GROUP_BRCM 23 /* Broadcom */ #define MACH_GROUP_BRCM 23 /* Broadcom */
#define MACH_BCM47XX 1 /* Broadcom BCM47XX */ #define MACH_BCM47XX 1 /* Broadcom BCM47XX */
@ -87,10 +82,9 @@ diff -urN linux-2.6.24.7/include/asm-mips/bootinfo.h linux-2.6.24.7.new/include/
#define CL_SIZE COMMAND_LINE_SIZE #define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void); const char *get_system_type(void);
diff -urN linux-2.6.24.7/include/asm-mips/cpu.h linux-2.6.24.7.new/include/asm-mips/cpu.h --- a/include/asm-mips/cpu.h
--- linux-2.6.24.7/include/asm-mips/cpu.h 2008-05-07 01:22:34.000000000 +0200 +++ b/include/asm-mips/cpu.h
+++ linux-2.6.24.7.new/include/asm-mips/cpu.h 2008-07-15 15:32:22.000000000 +0200 @@ -196,7 +196,7 @@ enum cpu_type_enum {
@@ -196,7 +196,7 @@
*/ */
CPU_4KC, CPU_4KEC, CPU_4KSC, CPU_24K, CPU_34K, CPU_74K, CPU_AU1000, CPU_4KC, CPU_4KEC, CPU_4KSC, CPU_24K, CPU_34K, CPU_74K, CPU_AU1000,
CPU_AU1100, CPU_AU1200, CPU_AU1500, CPU_AU1550, CPU_PR4450, CPU_AU1100, CPU_AU1200, CPU_AU1500, CPU_AU1550, CPU_PR4450,

View file

@ -1,10 +1,8 @@
Index: linux-2.6.23.17/drivers/net/Kconfig --- a/drivers/net/Kconfig
=================================================================== +++ b/drivers/net/Kconfig
--- linux-2.6.23.17.orig/drivers/net/Kconfig @@ -362,6 +362,13 @@ config AX88796_93CX6
+++ linux-2.6.23.17/drivers/net/Kconfig help
@@ -348,6 +348,13 @@ config AX88796 Select this if your platform comes with an external 93CX6 eeprom.
AX88796 driver, using platform bus to provide
chip detection and resources
+config KORINA +config KORINA
+ tristate "Korina Local Ethernet support" + tristate "Korina Local Ethernet support"
@ -16,11 +14,9 @@ Index: linux-2.6.23.17/drivers/net/Kconfig
config MACE config MACE
tristate "MACE (Power Mac ethernet) support" tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32 depends on PPC_PMAC && PPC32
Index: linux-2.6.23.17/drivers/net/Makefile --- a/drivers/net/Makefile
=================================================================== +++ b/drivers/net/Makefile
--- linux-2.6.23.17.orig/drivers/net/Makefile @@ -30,6 +30,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
+++ linux-2.6.23.17/drivers/net/Makefile
@@ -25,6 +25,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
# #
obj-$(CONFIG_PLIP) += plip.o obj-$(CONFIG_PLIP) += plip.o

View file

@ -1,8 +1,6 @@
Index: linux-2.6.23.17/drivers/block/Kconfig --- a/drivers/block/Kconfig
=================================================================== +++ b/drivers/block/Kconfig
--- linux-2.6.23.17.orig/drivers/block/Kconfig @@ -408,6 +408,14 @@ config SUNVDC
+++ linux-2.6.23.17/drivers/block/Kconfig
@@ -426,6 +426,14 @@ config SUNVDC
Support for virtual disk devices as a client under Sun Support for virtual disk devices as a client under Sun
Logical Domains. Logical Domains.
@ -17,10 +15,8 @@ Index: linux-2.6.23.17/drivers/block/Kconfig
source "drivers/s390/block/Kconfig" source "drivers/s390/block/Kconfig"
config XILINX_SYSACE config XILINX_SYSACE
Index: linux-2.6.23.17/drivers/block/Makefile --- a/drivers/block/Makefile
=================================================================== +++ b/drivers/block/Makefile
--- linux-2.6.23.17.orig/drivers/block/Makefile
+++ linux-2.6.23.17/drivers/block/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_BLK_DEV_DAC960) += DAC960.o @@ -21,6 +21,7 @@ obj-$(CONFIG_BLK_DEV_DAC960) += DAC960.o
obj-$(CONFIG_XILINX_SYSACE) += xsysace.o obj-$(CONFIG_XILINX_SYSACE) += xsysace.o
obj-$(CONFIG_CDROM_PKTCDVD) += pktcdvd.o obj-$(CONFIG_CDROM_PKTCDVD) += pktcdvd.o

View file

@ -1,8 +1,6 @@
Index: linux-2.6.23.17/arch/mips/kernel/head.S --- a/arch/mips/kernel/head.S
=================================================================== +++ b/arch/mips/kernel/head.S
--- linux-2.6.23.17.orig/arch/mips/kernel/head.S @@ -122,6 +122,10 @@
+++ linux-2.6.23.17/arch/mips/kernel/head.S
@@ -132,6 +132,10 @@
j kernel_entry j kernel_entry
nop nop

View file

@ -1,7 +1,5 @@
Index: linux-2.6.23.17/arch/mips/pci/pci.c --- a/arch/mips/pci/pci.c
=================================================================== +++ b/arch/mips/pci/pci.c
--- linux-2.6.23.17.orig/arch/mips/pci/pci.c
+++ linux-2.6.23.17/arch/mips/pci/pci.c
@@ -64,8 +64,10 @@ pcibios_align_resource(void *data, struc @@ -64,8 +64,10 @@ pcibios_align_resource(void *data, struc
/* /*
* Put everything into 0x00-0xff region modulo 0x400 * Put everything into 0x00-0xff region modulo 0x400

View file

@ -1,7 +1,5 @@
Index: linux-2.6.23.17/drivers/serial/8250.c --- a/drivers/serial/8250.c
=================================================================== +++ b/drivers/serial/8250.c
--- linux-2.6.23.17.orig/drivers/serial/8250.c
+++ linux-2.6.23.17/drivers/serial/8250.c
@@ -433,6 +433,13 @@ serial_out(struct uart_8250_port *up, in @@ -433,6 +433,13 @@ serial_out(struct uart_8250_port *up, in
default: default:
outb(value, up->port.iobase + offset); outb(value, up->port.iobase + offset);

View file

@ -1,7 +1,5 @@
Index: linux-2.6.23.17/drivers/net/via-rhine.c --- a/drivers/net/via-rhine.c
=================================================================== +++ b/drivers/net/via-rhine.c
--- linux-2.6.23.17.orig/drivers/net/via-rhine.c
+++ linux-2.6.23.17/drivers/net/via-rhine.c
@@ -33,6 +33,8 @@ @@ -33,6 +33,8 @@
#define DRV_VERSION "1.4.3" #define DRV_VERSION "1.4.3"
#define DRV_RELDATE "2007-03-06" #define DRV_RELDATE "2007-03-06"
@ -52,7 +50,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
/* /*
Theory of Operation Theory of Operation
@@ -927,7 +934,7 @@ static void alloc_rbufs(struct net_devic @@ -922,7 +929,7 @@ static void alloc_rbufs(struct net_devic
/* Fill in the Rx buffers. Handle allocation failure gracefully. */ /* Fill in the Rx buffers. Handle allocation failure gracefully. */
for (i = 0; i < RX_RING_SIZE; i++) { for (i = 0; i < RX_RING_SIZE; i++) {
@ -61,7 +59,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
rp->rx_skbuff[i] = skb; rp->rx_skbuff[i] = skb;
if (skb == NULL) if (skb == NULL)
break; break;
@@ -1484,7 +1491,9 @@ static int rhine_rx(struct net_device *d @@ -1485,7 +1492,9 @@ static int rhine_rx(struct net_device *d
struct sk_buff *skb; struct sk_buff *skb;
/* Length should omit the CRC */ /* Length should omit the CRC */
int pkt_len = data_size - 4; int pkt_len = data_size - 4;
@ -72,7 +70,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
/* Check if the packet is long enough to accept without /* Check if the packet is long enough to accept without
copying to a minimally-sized skbuff. */ copying to a minimally-sized skbuff. */
if (pkt_len < rx_copybreak && if (pkt_len < rx_copybreak &&
@@ -1503,7 +1512,9 @@ static int rhine_rx(struct net_device *d @@ -1504,7 +1513,9 @@ static int rhine_rx(struct net_device *d
rp->rx_skbuff_dma[entry], rp->rx_skbuff_dma[entry],
rp->rx_buf_sz, rp->rx_buf_sz,
PCI_DMA_FROMDEVICE); PCI_DMA_FROMDEVICE);
@ -83,7 +81,7 @@ Index: linux-2.6.23.17/drivers/net/via-rhine.c
skb = rp->rx_skbuff[entry]; skb = rp->rx_skbuff[entry];
if (skb == NULL) { if (skb == NULL) {
printk(KERN_ERR "%s: Inconsistent Rx " printk(KERN_ERR "%s: Inconsistent Rx "
@@ -1517,6 +1528,14 @@ static int rhine_rx(struct net_device *d @@ -1518,6 +1529,14 @@ static int rhine_rx(struct net_device *d
rp->rx_skbuff_dma[entry], rp->rx_skbuff_dma[entry],
rp->rx_buf_sz, rp->rx_buf_sz,
PCI_DMA_FROMDEVICE); PCI_DMA_FROMDEVICE);

View file

@ -1,7 +1,6 @@
diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
--- linux-2.6.24.7/drivers/leds/Kconfig 2008-07-15 15:27:55.000000000 +0200 +++ b/drivers/leds/Kconfig
+++ linux-2.6.24.7.new/drivers/leds/Kconfig 2008-07-15 15:35:24.000000000 +0200 @@ -120,6 +120,12 @@ config LEDS_CM_X270
@@ -120,6 +120,12 @@
help help
This option enables support for the CM-X270 LEDs. This option enables support for the CM-X270 LEDs.
@ -14,10 +13,9 @@ diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kc
comment "LED Triggers" comment "LED Triggers"
config LEDS_TRIGGERS config LEDS_TRIGGERS
diff -urN linux-2.6.24.7/drivers/leds/Makefile linux-2.6.24.7.new/drivers/leds/Makefile --- a/drivers/leds/Makefile
--- linux-2.6.24.7/drivers/leds/Makefile 2008-07-15 15:27:55.000000000 +0200 +++ b/drivers/leds/Makefile
+++ linux-2.6.24.7.new/drivers/leds/Makefile 2008-07-15 15:35:38.000000000 +0200 @@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-
@@ -20,6 +20,7 @@
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o

View file

@ -1,7 +1,6 @@
diff -urN linux-2.6.24.7/arch/mips/kernel/time.c linux-2.6.24.7.new/arch/mips/kernel/time.c --- a/arch/mips/kernel/time.c
--- linux-2.6.24.7/arch/mips/kernel/time.c 2008-05-07 01:22:34.000000000 +0200 +++ b/arch/mips/kernel/time.c
+++ linux-2.6.24.7.new/arch/mips/kernel/time.c 2008-07-15 15:38:33.000000000 +0200 @@ -75,6 +75,7 @@ EXPORT_SYMBOL(perf_irq);
@@ -75,6 +75,7 @@
*/ */
unsigned int mips_hpt_frequency; unsigned int mips_hpt_frequency;
@ -9,10 +8,9 @@ diff -urN linux-2.6.24.7/arch/mips/kernel/time.c linux-2.6.24.7.new/arch/mips/ke
void __init clocksource_set_clock(struct clocksource *cs, unsigned int clock) void __init clocksource_set_clock(struct clocksource *cs, unsigned int clock)
{ {
diff -urN linux-2.6.24.7/drivers/watchdog/Kconfig linux-2.6.24.7.new/drivers/watchdog/Kconfig --- a/drivers/watchdog/Kconfig
--- linux-2.6.24.7/drivers/watchdog/Kconfig 2008-05-07 01:22:34.000000000 +0200 +++ b/drivers/watchdog/Kconfig
+++ linux-2.6.24.7.new/drivers/watchdog/Kconfig 2008-07-15 15:39:24.000000000 +0200 @@ -639,6 +639,18 @@ config AR7_WDT
@@ -639,6 +639,18 @@
help help
Hardware driver for the TI AR7 Watchdog Timer. Hardware driver for the TI AR7 Watchdog Timer.

View file

@ -1,7 +1,6 @@
diff -urN linux-2.6.24.7/arch/mips/lib/iomap-pci.c linux-2.6.24.7.new/arch/mips/lib/iomap-pci.c --- a/arch/mips/lib/iomap-pci.c
--- linux-2.6.24.7/arch/mips/lib/iomap-pci.c 2008-05-07 01:22:34.000000000 +0200 +++ b/arch/mips/lib/iomap-pci.c
+++ linux-2.6.24.7.new/arch/mips/lib/iomap-pci.c 2008-07-15 16:24:22.000000000 +0200 @@ -32,7 +32,7 @@ static void __iomem *ioport_map_pci(stru
@@ -32,7 +32,7 @@
"report it to linux-mips@linux-mips.org or your " "report it to linux-mips@linux-mips.org or your "
"vendor.\n", name); "vendor.\n", name);
#ifdef CONFIG_PCI_DOMAINS #ifdef CONFIG_PCI_DOMAINS