kernel: disable MIPS VDSO by default until the cache issues have been resolved
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48802
This commit is contained in:
parent
b5bfb3534b
commit
1185e645a7
1 changed files with 21 additions and 0 deletions
21
target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
Normal file
21
target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
Disable MIPS VDSO until the cache issues have been sorted out.
|
||||||
|
|
||||||
|
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||||
|
|
||||||
|
--- a/arch/mips/vdso/Makefile
|
||||||
|
+++ b/arch/mips/vdso/Makefile
|
||||||
|
@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
|
||||||
|
# the comments on that file.
|
||||||
|
#
|
||||||
|
ifndef CONFIG_CPU_MIPSR6
|
||||||
|
- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
|
||||||
|
- $(warning MIPS VDSO requires binutils >= 2.25)
|
||||||
|
+# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
|
||||||
|
+# $(warning MIPS VDSO requires binutils >= 2.25)
|
||||||
|
obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
||||||
|
ccflags-vdso += -DDISABLE_MIPS_VDSO
|
||||||
|
- endif
|
||||||
|
+# endif
|
||||||
|
endif
|
||||||
|
|
||||||
|
# VDSO linker flags.
|
Loading…
Reference in a new issue