curl: bump to 7.60.0
Refresh patches; remove 320-mbedtls_dont_use_deprecated_sha256_function patch as upstream fixed For changes in version 2.60 see https://curl.haxx.se/changes.html#7_60_0 Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
afbb3d20f2
commit
0ed9281fda
3 changed files with 4 additions and 15 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=7.59.0
|
PKG_VERSION:=7.60.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
||||||
http://curl.mirror.anstey.ca/ \
|
http://curl.mirror.anstey.ca/ \
|
||||||
http://curl.askapache.com/download/ \
|
http://curl.askapache.com/download/ \
|
||||||
https://curl.haxx.se/download/
|
https://curl.haxx.se/download/
|
||||||
PKG_HASH:=e44eaabdf916407585bf5c7939ff1161e6242b6b015d3f2f5b758b2a330461fc
|
PKG_HASH:=8736ff8ded89ddf7e926eec7b16f82597d029fc1469f3a551f1fafaac164e6a0
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -6,6 +6,6 @@
|
||||||
{
|
{
|
||||||
- unsigned int version = mbedtls_version_get_number();
|
- unsigned int version = mbedtls_version_get_number();
|
||||||
+ unsigned int version = MBEDTLS_VERSION_NUMBER;
|
+ unsigned int version = MBEDTLS_VERSION_NUMBER;
|
||||||
return snprintf(buffer, size, "mbedTLS/%d.%d.%d", version>>24,
|
return snprintf(buffer, size, "mbedTLS/%u.%u.%u", version>>24,
|
||||||
(version>>16)&0xff, (version>>8)&0xff);
|
(version>>16)&0xff, (version>>8)&0xff);
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/lib/vtls/mbedtls.c
|
|
||||||
+++ b/lib/vtls/mbedtls.c
|
|
||||||
@@ -1029,7 +1029,7 @@ static void Curl_mbedtls_sha256sum(const
|
|
||||||
size_t sha256len UNUSED_PARAM)
|
|
||||||
{
|
|
||||||
(void)sha256len;
|
|
||||||
- mbedtls_sha256(input, inputlen, sha256sum, 0);
|
|
||||||
+ mbedtls_sha256_ret(input, inputlen, sha256sum, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void *Curl_mbedtls_get_internals(struct ssl_connect_data *connssl,
|
|
Loading…
Reference in a new issue