package/acx: refresh patches
SVN-Revision: 20448
This commit is contained in:
parent
8356fc0b8e
commit
0bf7a71a2a
5 changed files with 30 additions and 39 deletions
|
@ -1,8 +1,6 @@
|
|||
Index: acx-20070101/Makefile
|
||||
===================================================================
|
||||
--- acx-20070101.orig/Makefile 2007-06-04 13:22:42.463399864 +0200
|
||||
+++ acx-20070101/Makefile 2007-06-04 13:22:42.747356696 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -4,7 +4,7 @@ KERNELDIR = /lib/modules/$(KVER)/build
|
||||
obj-m += acx.o
|
||||
|
||||
acx-obj-y += pci.o
|
||||
|
@ -11,15 +9,13 @@ Index: acx-20070101/Makefile
|
|||
|
||||
acx-objs := wlan.o conv.o ioctl.o common.o $(acx-obj-y)
|
||||
|
||||
Index: acx-20070101/acx_config.h
|
||||
===================================================================
|
||||
--- acx-20070101.orig/acx_config.h 2007-06-04 13:22:42.469398952 +0200
|
||||
+++ acx-20070101/acx_config.h 2007-06-04 13:22:42.747356696 +0200
|
||||
--- a/acx_config.h
|
||||
+++ b/acx_config.h
|
||||
@@ -1,6 +1,6 @@
|
||||
/* temporary hack until proper Kconfig integration */
|
||||
#define CONFIG_ACX_PCI 1
|
||||
-#define CONFIG_ACX_USB 1
|
||||
+/*#define CONFIG_ACX_USB 1*/
|
||||
|
||||
#define ACX_RELEASE "v0.3.36"
|
||||
#define ACX_RELEASE "v0.3.37"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- acx-20080210/common.c.orig 2008-04-19 17:38:46.000000000 +0100
|
||||
+++ acx-20080210/common.c 2008-04-19 17:40:10.000000000 +0100
|
||||
@@ -4155,6 +4155,11 @@
|
||||
--- a/common.c
|
||||
+++ b/common.c
|
||||
@@ -4155,6 +4155,11 @@ acx_l_process_data_frame_master(acx_devi
|
||||
/* To_DS = 0, From_DS = 1 */
|
||||
hdr->fc = WF_FC_FROMDSi + WF_FTYPE_DATAi;
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- acx-20080210/ioctl.c 2008-02-10 14:06:42.000000000 -0600
|
||||
+++ ioctl.c 2008-11-16 02:08:58.000000000 -0600
|
||||
@@ -488,6 +488,7 @@
|
||||
--- a/ioctl.c
|
||||
+++ b/ioctl.c
|
||||
@@ -488,6 +488,7 @@ end_unlock:
|
||||
/* helper. not sure whether it's really a _s_leeping fn */
|
||||
static char*
|
||||
acx_s_scan_add_station(
|
||||
|
@ -8,7 +8,7 @@
|
|||
acx_device_t *adev,
|
||||
char *ptr,
|
||||
char *end_buf,
|
||||
@@ -503,14 +504,14 @@
|
||||
@@ -503,14 +504,14 @@ acx_s_scan_add_station(
|
||||
iwe.u.ap_addr.sa_family = ARPHRD_ETHER;
|
||||
MAC_COPY(iwe.u.ap_addr.sa_data, bss->bssid);
|
||||
acxlog_mac(L_IOCTL, "scan, station address: ", bss->bssid, "\n");
|
||||
|
@ -25,7 +25,7 @@
|
|||
|
||||
/* Add mode */
|
||||
iwe.cmd = SIOCGIWMODE;
|
||||
@@ -520,7 +521,7 @@
|
||||
@@ -520,7 +521,7 @@ acx_s_scan_add_station(
|
||||
else
|
||||
iwe.u.mode = IW_MODE_ADHOC;
|
||||
log(L_IOCTL, "scan, mode: %d\n", iwe.u.mode);
|
||||
|
@ -34,7 +34,7 @@
|
|||
}
|
||||
|
||||
/* Add frequency */
|
||||
@@ -528,7 +529,7 @@
|
||||
@@ -528,7 +529,7 @@ acx_s_scan_add_station(
|
||||
iwe.u.freq.m = acx_channel_freq[bss->channel - 1] * 100000;
|
||||
iwe.u.freq.e = 1;
|
||||
log(L_IOCTL, "scan, frequency: %d\n", iwe.u.freq.m);
|
||||
|
@ -43,7 +43,7 @@
|
|||
|
||||
/* Add link quality */
|
||||
iwe.cmd = IWEVQUAL;
|
||||
@@ -546,7 +547,7 @@
|
||||
@@ -546,7 +547,7 @@ acx_s_scan_add_station(
|
||||
iwe.u.qual.updated = 7;
|
||||
log(L_IOCTL, "scan, link quality: %d/%d/%d\n",
|
||||
iwe.u.qual.level, iwe.u.qual.noise, iwe.u.qual.qual);
|
||||
|
@ -52,7 +52,7 @@
|
|||
|
||||
/* Add encryption */
|
||||
iwe.cmd = SIOCGIWENCODE;
|
||||
@@ -556,7 +557,7 @@
|
||||
@@ -556,7 +557,7 @@ acx_s_scan_add_station(
|
||||
iwe.u.data.flags = IW_ENCODE_DISABLED;
|
||||
iwe.u.data.length = 0;
|
||||
log(L_IOCTL, "scan, encryption flags: %X\n", iwe.u.data.flags);
|
||||
|
@ -61,7 +61,7 @@
|
|||
|
||||
/* add rates */
|
||||
iwe.cmd = SIOCGIWRATE;
|
||||
@@ -570,7 +571,7 @@
|
||||
@@ -570,7 +571,7 @@ acx_s_scan_add_station(
|
||||
if (rate & 1) {
|
||||
iwe.u.bitrate.value = *p * 500000; /* units of 500kb/s */
|
||||
log(L_IOCTL, "scan, rate: %d\n", iwe.u.bitrate.value);
|
||||
|
@ -70,7 +70,7 @@
|
|||
&iwe, IW_EV_PARAM_LEN);
|
||||
}
|
||||
rate >>= 1;
|
||||
@@ -625,7 +626,7 @@
|
||||
@@ -625,7 +626,7 @@ acx_ioctl_get_scan(
|
||||
for (i = 0; i < ARRAY_SIZE(adev->sta_list); i++) {
|
||||
struct client *bss = &adev->sta_list[i];
|
||||
if (!bss->used) continue;
|
||||
|
@ -79,4 +79,3 @@
|
|||
extra + IW_SCAN_MAX_DATA, bss);
|
||||
}
|
||||
dwrq->length = ptr - extra;
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -urN acx-20080210/pci.c acx-20080210.new/pci.c
|
||||
--- acx-20080210/pci.c 2009-08-04 00:28:37.000000000 +0200
|
||||
+++ acx-20080210.new/pci.c 2009-08-04 00:28:42.000000000 +0200
|
||||
@@ -2005,7 +2005,12 @@
|
||||
--- a/pci.c
|
||||
+++ b/pci.c
|
||||
@@ -2005,7 +2005,12 @@ static void acxpci_s_down(struct net_dev
|
||||
/* then wait until interrupts have finished executing on other CPUs */
|
||||
acx_lock(adev, flags);
|
||||
disable_acx_irq(adev);
|
||||
|
@ -14,7 +13,7 @@ diff -urN acx-20080210/pci.c acx-20080210.new/pci.c
|
|||
acx_unlock(adev, flags);
|
||||
|
||||
/* we really don't want to have an asynchronous tasklet disturb us
|
||||
@@ -4164,7 +4169,11 @@
|
||||
@@ -4164,7 +4169,11 @@ static __devinit int vlynq_probe(struct
|
||||
addr = (u32)ioremap(vdev->mem_start, 0x1000);
|
||||
if (!addr) {
|
||||
printk(KERN_ERR "%s: failed to remap io memory\n",
|
||||
|
@ -26,7 +25,7 @@ diff -urN acx-20080210/pci.c acx-20080210.new/pci.c
|
|||
result = -ENXIO;
|
||||
goto fail;
|
||||
}
|
||||
@@ -4231,7 +4240,11 @@
|
||||
@@ -4231,7 +4240,11 @@ static __devinit int vlynq_probe(struct
|
||||
|
||||
printk("acx: found %s-based wireless network card at %s, irq:%d, "
|
||||
"phymem:0x%x, mem:0x%p\n",
|
||||
|
@ -38,9 +37,8 @@ diff -urN acx-20080210/pci.c acx-20080210.new/pci.c
|
|||
vdev->mem_start, adev->iobase);
|
||||
log(L_ANY, "initial debug setting is 0x%04X\n", acx_debug);
|
||||
|
||||
diff -urN acx-20080210/wlan_compat.h acx-20080210.new/wlan_compat.h
|
||||
--- acx-20080210/wlan_compat.h 2008-02-10 21:06:42.000000000 +0100
|
||||
+++ acx-20080210.new/wlan_compat.h 2009-08-04 00:24:26.000000000 +0200
|
||||
--- a/wlan_compat.h
|
||||
+++ b/wlan_compat.h
|
||||
@@ -221,8 +221,10 @@
|
||||
#ifndef IRQ_NONE
|
||||
#define IRQ_NONE
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: acx-20080210/pci.c
|
||||
===================================================================
|
||||
--- acx-20080210.orig/pci.c 2010-03-06 13:43:06.000000000 +0100
|
||||
+++ acx-20080210/pci.c 2010-03-06 13:46:38.000000000 +0100
|
||||
@@ -4135,6 +4135,18 @@
|
||||
--- a/pci.c
|
||||
+++ b/pci.c
|
||||
@@ -4135,6 +4135,18 @@ static struct vlynq_device_id acx_vlynq_
|
||||
{ 0, 0, 0 },
|
||||
};
|
||||
|
||||
|
@ -21,7 +19,7 @@ Index: acx-20080210/pci.c
|
|||
static __devinit int vlynq_probe(struct vlynq_device *vdev,
|
||||
struct vlynq_device_id *id)
|
||||
{
|
||||
@@ -4191,17 +4203,24 @@
|
||||
@@ -4191,17 +4203,24 @@ static __devinit int vlynq_probe(struct
|
||||
goto fail_alloc_netdev;
|
||||
}
|
||||
ether_setup(ndev);
|
||||
|
|
Loading…
Reference in a new issue