atheros: remove odd ATHEROS_AR2315 config symbol dependencies
Remove options which already selected by ATHEROS_AR231X on which ATHEROS_AR2315 depends. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 42497
This commit is contained in:
parent
2e9deed90a
commit
09f38a3f76
2 changed files with 4 additions and 11 deletions
|
@ -49,7 +49,7 @@
|
|||
+load-$(CONFIG_ATHEROS_AR231X) += 0xffffffff80041000
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ar231x/Kconfig
|
||||
@@ -0,0 +1,16 @@
|
||||
@@ -0,0 +1,9 @@
|
||||
+config ATHEROS_AR5312
|
||||
+ bool "Atheros 5312/2312+ support"
|
||||
+ depends on ATHEROS_AR231X
|
||||
|
@ -58,13 +58,6 @@
|
|||
+config ATHEROS_AR2315
|
||||
+ bool "Atheros 2315+ support"
|
||||
+ depends on ATHEROS_AR231X
|
||||
+ select DMA_NONCOHERENT
|
||||
+ select CEVT_R4K
|
||||
+ select CSRC_R4K
|
||||
+ select IRQ_CPU
|
||||
+ select SYS_HAS_CPU_MIPS32_R1
|
||||
+ select SYS_SUPPORTS_32BIT_KERNEL
|
||||
+ select SYS_SUPPORTS_BIG_ENDIAN
|
||||
+ default y
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ar231x/Makefile
|
||||
|
|
|
@ -243,9 +243,9 @@
|
|||
+arch_initcall(ar2315_pci_init);
|
||||
--- a/arch/mips/ar231x/Kconfig
|
||||
+++ b/arch/mips/ar231x/Kconfig
|
||||
@@ -14,3 +14,10 @@ config ATHEROS_AR2315
|
||||
select SYS_SUPPORTS_32BIT_KERNEL
|
||||
select SYS_SUPPORTS_BIG_ENDIAN
|
||||
@@ -7,3 +7,10 @@ config ATHEROS_AR2315
|
||||
bool "Atheros 2315+ support"
|
||||
depends on ATHEROS_AR231X
|
||||
default y
|
||||
+
|
||||
+config ATHEROS_AR2315_PCI
|
||||
|
|
Loading…
Reference in a new issue