lantiq: ltq-vdsl: update to version 4.16.6.3
In addition to the update this also fixes some build warnings and makes it use the same configure option as used in Lantiq UGW. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com> SVN-Revision: 47635
This commit is contained in:
parent
5d236c4dd0
commit
091b668f1a
2 changed files with 12 additions and 22 deletions
|
@ -1,4 +1,5 @@
|
|||
# Copyright (C) 2012 OpenWrt.org
|
||||
# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -7,14 +8,14 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ltq-vdsl-vr9
|
||||
PKG_VERSION:=4.16.2.4
|
||||
PKG_VERSION:=4.16.6.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BASE_NAME:=drv_dsl_cpe_api_vrx
|
||||
PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_BASE_NAME:=drv_dsl_cpe_api
|
||||
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_BASE_NAME)/archive/v$(PKG_VERSION)
|
||||
PKG_MD5SUM:=0a3e35d199eb8936f3e8f61bb074223a
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=5b15a866bb1939c333d30a1b7f9e7856
|
||||
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
|
@ -56,11 +57,10 @@ CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
|
|||
--enable-adsl-led=no \
|
||||
--enable-adsl-mib=no \
|
||||
--enable-dsl-ceoc=no \
|
||||
--enable-dsl-bonding=no \
|
||||
--enable-linux-26 \
|
||||
--enable-kernelbuild="$(LINUX_DIR)" \
|
||||
--enable-debug-prints=no \
|
||||
KERNEL_ARCH=mips
|
||||
ARCH=mips
|
||||
|
||||
CONFIGURE_ARGS += --enable-model=full
|
||||
#CONFIGURE_ARGS += --enable-model=lite
|
||||
|
|
|
@ -19,7 +19,7 @@
|
|||
#include "drv_dsl_cpe_api.h"
|
||||
#include "drv_dsl_cpe_api_ioctl.h"
|
||||
|
||||
@@ -238,24 +239,10 @@ static DSL_long_t DSL_DRV_Ioctls(DSL_DRV
|
||||
@@ -238,14 +239,7 @@ static DSL_long_t DSL_DRV_Ioctls(DSL_DRV
|
||||
}
|
||||
|
||||
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36))
|
||||
|
@ -34,18 +34,8 @@
|
|||
+ pINode = file_inode(pFile);
|
||||
#endif
|
||||
|
||||
- if (pINode == DSL_NULL)
|
||||
- {
|
||||
- bIsInKernel = DSL_TRUE;
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
bIsInKernel = DSL_FALSE;
|
||||
- }
|
||||
|
||||
if ( (_IOC_TYPE(nCommand) == DSL_IOC_MAGIC_CPE_API) ||
|
||||
(_IOC_TYPE(nCommand) == DSL_IOC_MAGIC_CPE_API_G997) ||
|
||||
@@ -1102,6 +1089,9 @@ static void DSL_DRV_DebugInit(void)
|
||||
if (pINode == DSL_NULL)
|
||||
@@ -1118,6 +1112,9 @@ static void DSL_DRV_DebugInit(void)
|
||||
return;
|
||||
}
|
||||
|
||||
|
@ -55,7 +45,7 @@
|
|||
/* Entry point of driver */
|
||||
int __init DSL_ModuleInit(void)
|
||||
{
|
||||
@@ -1140,6 +1130,10 @@ int __init DSL_ModuleInit(void)
|
||||
@@ -1156,6 +1153,10 @@ int __init DSL_ModuleInit(void)
|
||||
|
||||
DSL_DRV_DevNodeInit();
|
||||
|
||||
|
@ -66,7 +56,7 @@
|
|||
return 0;
|
||||
}
|
||||
|
||||
@@ -1147,6 +1141,11 @@ void __exit DSL_ModuleCleanup(void)
|
||||
@@ -1163,6 +1164,11 @@ void __exit DSL_ModuleCleanup(void)
|
||||
{
|
||||
printk("Module will be unloaded"DSL_DRV_CRLF);
|
||||
|
||||
|
|
Loading…
Reference in a new issue