kernel: update to kernel 3.10.1 and refresh patches
SVN-Revision: 37275
This commit is contained in:
parent
e574f75d16
commit
06accca1d7
8 changed files with 30 additions and 27 deletions
|
@ -17,8 +17,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.9.10)
|
||||
LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.10)
|
||||
LINUX_KERNEL_MD5SUM:=4f25cd5bec5f8d5a7d935b3f2ccb8481
|
||||
ifeq ($(LINUX_VERSION),3.10.1)
|
||||
LINUX_KERNEL_MD5SUM:=4c8ed240943c8750a89cc307637bd74d
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
|
|||
FEATURES:=squashfs usb pci pcie gpio
|
||||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
|
||||
LINUX_VERSION:=3.10
|
||||
LINUX_VERSION:=3.10.1
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ BOARDNAME:=Broadcom BCM2708/BCM2835
|
|||
FEATURES:=ext4 audio usb usbgadget display gpio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10
|
||||
LINUX_VERSION:=3.10.1
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
|
||||
|
|
|
@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
#ifdef MODULE
|
||||
#define __MODULE_INFO(tag, name, info) \
|
||||
static const char __UNIQUE_ID(name)[] \
|
||||
@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
|
||||
@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
|
||||
= __stringify(tag) "=" info
|
||||
#else /* !MODULE */
|
||||
/* This struct is here for syntactic coherency, it is not used */
|
||||
|
@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
#endif
|
||||
#define __MODULE_PARM_TYPE(name, _type) \
|
||||
__MODULE_INFO(parmtype, name##type, #name ":" _type)
|
||||
@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
|
||||
@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
|
||||
/* One for each parameter, describing how to use it. Some files do
|
||||
multiple of these per line, so can't just use MODULE_INFO. */
|
||||
#define MODULE_PARM_DESC(_parm, desc) \
|
||||
|
|
|
@ -124,7 +124,7 @@
|
|||
/* LzmaDecode
|
||||
--- a/lib/lzma/LzmaDec.c
|
||||
+++ b/lib/lzma/LzmaDec.c
|
||||
@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
|
||||
@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
|
||||
p->needFlush = 0;
|
||||
}
|
||||
|
||||
|
@ -219,26 +219,26 @@
|
|||
{
|
||||
UInt32 dicSize;
|
||||
Byte d;
|
||||
@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
||||
@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
||||
return SZ_OK;
|
||||
}
|
||||
|
||||
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||
-{
|
||||
- CLzmaProps propNew;
|
||||
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||
- p->prop = propNew;
|
||||
- return SZ_OK;
|
||||
-}
|
||||
-
|
||||
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||
{
|
||||
CLzmaProps propNew;
|
||||
- SizeT dicBufSize;
|
||||
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||
RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||
@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
|
||||
p->prop = propNew;
|
||||
return SZ_OK;
|
||||
}
|
||||
-
|
||||
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||
-{
|
||||
- CLzmaProps propNew;
|
||||
- SizeT dicBufSize;
|
||||
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||
- dicBufSize = propNew.dicSize;
|
||||
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
|
||||
- {
|
||||
|
@ -251,9 +251,12 @@
|
|||
- }
|
||||
- }
|
||||
- p->dicBufSize = dicBufSize;
|
||||
p->prop = propNew;
|
||||
return SZ_OK;
|
||||
}
|
||||
- p->prop = propNew;
|
||||
- return SZ_OK;
|
||||
-}
|
||||
|
||||
SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
|
||||
const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
|
||||
--- a/include/linux/lzma/LzmaEnc.h
|
||||
+++ b/include/linux/lzma/LzmaEnc.h
|
||||
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
|
||||
|
@ -597,7 +600,7 @@
|
|||
void MatchFinder_Construct(CMatchFinder *p);
|
||||
|
||||
/* Conditions:
|
||||
@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
|
||||
@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
|
||||
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
|
||||
ISzAlloc *alloc);
|
||||
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
|
||||
|
@ -686,7 +689,7 @@
|
|||
{
|
||||
memmove(p->bufferBase,
|
||||
p->buffer - p->keepSizeBefore,
|
||||
@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
|
||||
@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
|
||||
p->buffer = p->bufferBase + p->keepSizeBefore;
|
||||
}
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX23 series
|
|||
FEATURES:=ext4 rtc usb gpio
|
||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
||||
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
||||
LINUX_VERSION:=3.10
|
||||
LINUX_VERSION:=3.10.1
|
||||
KERNELNAME:="zImage dtbs"
|
||||
#DEPENDS:=+imx-bootlets
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
|
|||
CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10
|
||||
LINUX_VERSION:=3.10.1
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=3.10
|
||||
LINUX_VERSION:=3.10.1
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
Loading…
Reference in a new issue