kernel: strip unnecessary symbol table information from kernel modules, reduces default squashfs size on ar71xx by about 4k
SVN-Revision: 30657
This commit is contained in:
parent
dd001a4b0f
commit
058d331a39
4 changed files with 24 additions and 2 deletions
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -374,7 +374,7 @@
|
||||||
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
|
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||||
|
+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
|
||||||
|
|
||||||
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
|
@ -3,7 +3,7 @@
|
||||||
@@ -375,6 +375,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
@@ -375,6 +375,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
|
||||||
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -374,7 +374,7 @@
|
||||||
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
|
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||||
|
+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
|
||||||
|
|
||||||
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
|
@ -3,7 +3,7 @@
|
||||||
@@ -375,6 +375,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
@@ -375,6 +375,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
|
||||||
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
|
Loading…
Reference in a new issue