disable dropbear zlib support and split off dropbearconvert to save flash space
SVN-Revision: 3085
This commit is contained in:
parent
4590caced7
commit
051931d5fb
4 changed files with 36 additions and 3 deletions
|
@ -2,9 +2,13 @@ config BR2_PACKAGE_DROPBEAR
|
||||||
prompt "dropbear.......................... Small SSH 2 client/server"
|
prompt "dropbear.......................... Small SSH 2 client/server"
|
||||||
tristate
|
tristate
|
||||||
default y
|
default y
|
||||||
select BR2_PACKAGE_ZLIB
|
|
||||||
help
|
help
|
||||||
A small SSH 2 server/client designed for small memory environments.
|
A small SSH 2 server/client designed for small memory environments.
|
||||||
|
|
||||||
http://matt.ucc.asn.au/dropbear/
|
http://matt.ucc.asn.au/dropbear/
|
||||||
|
|
||||||
|
config BR2_PACKAGE_DBCONVERT
|
||||||
|
prompt "dropbearconvert................... Utility for converting SSH keys"
|
||||||
|
tristate
|
||||||
|
default m if CONFIG_DEVEL
|
||||||
|
depends BR2_PACKAGE_DROPBEAR
|
||||||
|
|
|
@ -16,6 +16,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
$(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
$(eval $(call PKG_template,DBCONVERT,dropbearconvert,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
$(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
|
$(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
|
||||||
|
@ -58,15 +59,25 @@ $(PKG_BUILD_DIR)/.configured:
|
||||||
--disable-loginfunc \
|
--disable-loginfunc \
|
||||||
--disable-pututline \
|
--disable-pututline \
|
||||||
--disable-pututxline \
|
--disable-pututxline \
|
||||||
|
--disable-zlib \
|
||||||
);
|
);
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
$(PKG_BUILD_DIR)/.built:
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
LD=$(TARGET_CC) \
|
LD=$(TARGET_CC) \
|
||||||
PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
|
PROGRAMS="dropbear dbclient dropbearkey scp" \
|
||||||
MULTI=1 SCPPROGRESS=1
|
MULTI=1 SCPPROGRESS=1
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
LD=$(TARGET_CC) \
|
||||||
|
PROGRAMS="dropbearconvert"
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
|
$(IPKG_DBCONVERT):
|
||||||
|
mkdir -p $(IDIR_DBCONVERT)/usr/bin
|
||||||
|
install -m 755 $(PKG_BUILD_DIR)/dropbearconvert \
|
||||||
|
$(IDIR_DBCONVERT)/usr/bin/dropbearconvert
|
||||||
|
$(IPKG_BUILD) $(IDIR_DBCONVERT) $(PACKAGE_DIR)
|
||||||
|
|
||||||
$(IPKG_DROPBEAR):
|
$(IPKG_DROPBEAR):
|
||||||
mkdir -p $(IDIR_DROPBEAR)/usr/bin
|
mkdir -p $(IDIR_DROPBEAR)/usr/bin
|
||||||
|
@ -78,7 +89,6 @@ $(IPKG_DROPBEAR):
|
||||||
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
|
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
|
||||||
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
|
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
|
||||||
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
|
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
|
||||||
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearconvert
|
|
||||||
mkdir -p $(IDIR_DROPBEAR)/etc/init.d
|
mkdir -p $(IDIR_DROPBEAR)/etc/init.d
|
||||||
install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
|
install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
|
||||||
$(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
|
||||||
|
|
5
openwrt/package/dropbear/ipkg/dropbearconvert.control
Normal file
5
openwrt/package/dropbear/ipkg/dropbearconvert.control
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
Package: dropbearconvert
|
||||||
|
Priority: optional
|
||||||
|
Depends: zlib
|
||||||
|
Section: net
|
||||||
|
Description: Utility for converting SSH keys
|
|
@ -0,0 +1,14 @@
|
||||||
|
--- dropbear-0.47.old/options.h 2006-01-31 13:36:25.301562500 +0100
|
||||||
|
+++ dropbear-0.47.dev/options.h 2006-01-31 13:37:41.846346250 +0100
|
||||||
|
@@ -5,6 +5,11 @@
|
||||||
|
#ifndef _OPTIONS_H_
|
||||||
|
#define _OPTIONS_H_
|
||||||
|
|
||||||
|
+#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
|
||||||
|
+#define DROPBEAR_SERVER
|
||||||
|
+#define DROPBEAR_CLIENT
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/******************************************************************
|
||||||
|
* Define compile-time options below - the "#ifndef DROPBEAR_XXX .... #endif"
|
||||||
|
* parts are to allow for commandline -DDROPBEAR_XXX options etc.
|
Loading…
Reference in a new issue