refresh patches
SVN-Revision: 19781
This commit is contained in:
parent
42d947f5ba
commit
046c32e6bf
24 changed files with 81 additions and 81 deletions
|
@ -31,7 +31,7 @@
|
|||
}
|
||||
--- a/drivers/ssb/main.c
|
||||
+++ b/drivers/ssb/main.c
|
||||
@@ -1010,6 +1010,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
@@ -1012,6 +1012,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
|
||||
if (bus->chip_id == 0x5365) {
|
||||
rate = 100000000;
|
||||
|
|
|
@ -90,7 +90,7 @@
|
|||
{
|
||||
char buf[CL_SIZE];
|
||||
|
||||
@@ -146,9 +122,12 @@ static __init void prom_init_mem(void)
|
||||
@@ -154,9 +130,12 @@ static __init void prom_init_mem(void)
|
||||
|
||||
void __init prom_init(void)
|
||||
{
|
||||
|
|
|
@ -15,7 +15,7 @@
|
|||
extern char *system_type;
|
||||
--- a/include/linux/pci_ids.h
|
||||
+++ b/include/linux/pci_ids.h
|
||||
@@ -2085,6 +2085,7 @@
|
||||
@@ -2089,6 +2089,7 @@
|
||||
#define PCI_DEVICE_ID_TIGON3_5906M 0x1713
|
||||
#define PCI_DEVICE_ID_BCM4401 0x4401
|
||||
#define PCI_DEVICE_ID_BCM4401B0 0x4402
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
}
|
||||
|
||||
static void __b44_set_flow_ctrl(struct b44 *bp, u32 pause_flags)
|
||||
@@ -2221,6 +2221,10 @@ static int __devinit b44_init_one(struct
|
||||
@@ -2217,6 +2217,10 @@ static int __devinit b44_init_one(struct
|
||||
*/
|
||||
b44_chip_reset(bp, B44_CHIP_RESET_FULL);
|
||||
|
||||
|
|
|
@ -31,7 +31,7 @@
|
|||
}
|
||||
--- a/drivers/ssb/main.c
|
||||
+++ b/drivers/ssb/main.c
|
||||
@@ -1010,6 +1010,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
@@ -1012,6 +1012,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
|
||||
if (bus->chip_id == 0x5365) {
|
||||
rate = 100000000;
|
||||
|
|
|
@ -29,7 +29,7 @@
|
|||
depends on USB
|
||||
--- a/drivers/usb/host/ehci-hcd.c
|
||||
+++ b/drivers/usb/host/ehci-hcd.c
|
||||
@@ -1117,8 +1117,16 @@ MODULE_LICENSE ("GPL");
|
||||
@@ -1119,8 +1119,16 @@ MODULE_LICENSE ("GPL");
|
||||
#define PLATFORM_DRIVER ixp4xx_ehci_driver
|
||||
#endif
|
||||
|
||||
|
|
|
@ -90,7 +90,7 @@
|
|||
{
|
||||
char buf[CL_SIZE];
|
||||
|
||||
@@ -146,9 +122,12 @@ static __init void prom_init_mem(void)
|
||||
@@ -154,9 +130,12 @@ static __init void prom_init_mem(void)
|
||||
|
||||
void __init prom_init(void)
|
||||
{
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/arch/mips/include/asm/bootinfo.h
|
||||
+++ b/arch/mips/include/asm/bootinfo.h
|
||||
@@ -57,6 +57,12 @@
|
||||
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
|
||||
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
|
||||
@@ -69,6 +69,12 @@
|
||||
#define MACH_DEXXON_GDIUM2F10 5
|
||||
#define MACH_LOONGSON_END 6
|
||||
|
||||
+/*
|
||||
+ * Valid machtype for group Broadcom
|
||||
|
@ -15,7 +15,7 @@
|
|||
extern char *system_type;
|
||||
--- a/include/linux/pci_ids.h
|
||||
+++ b/include/linux/pci_ids.h
|
||||
@@ -2106,6 +2106,7 @@
|
||||
@@ -2101,6 +2101,7 @@
|
||||
#define PCI_DEVICE_ID_TIGON3_5906M 0x1713
|
||||
#define PCI_DEVICE_ID_BCM4401 0x4401
|
||||
#define PCI_DEVICE_ID_BCM4401B0 0x4402
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/maps/Kconfig
|
||||
+++ b/drivers/mtd/maps/Kconfig
|
||||
@@ -343,6 +343,12 @@ config MTD_CFI_FLAGADM
|
||||
@@ -327,6 +327,12 @@ config MTD_CFI_FLAGADM
|
||||
Mapping for the Flaga digital module. If you don't have one, ignore
|
||||
this setting.
|
||||
|
||||
|
@ -15,7 +15,7 @@
|
|||
depends on MTD_CFI && ( REDWOOD_4 || REDWOOD_5 || REDWOOD_6 )
|
||||
--- a/drivers/mtd/maps/Makefile
|
||||
+++ b/drivers/mtd/maps/Makefile
|
||||
@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcm
|
||||
@@ -28,6 +28,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
|
||||
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
|
||||
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
|
||||
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -195,7 +195,6 @@ config MIPS_MALTA
|
||||
@@ -216,7 +216,6 @@ config MIPS_MALTA
|
||||
select I8259
|
||||
select MIPS_BOARDS_GEN
|
||||
select MIPS_BONITO64
|
||||
|
@ -8,7 +8,7 @@
|
|||
select PCI_GT64XXX_PCI0
|
||||
select MIPS_MSC
|
||||
select SWAP_IO_SPACE
|
||||
@@ -1473,13 +1472,6 @@ config IP22_CPU_SCACHE
|
||||
@@ -1523,13 +1522,6 @@ config IP22_CPU_SCACHE
|
||||
bool
|
||||
select BOARD_SCACHE
|
||||
|
||||
|
@ -24,7 +24,7 @@
|
|||
select BOARD_SCACHE
|
||||
--- a/arch/mips/kernel/cpu-probe.c
|
||||
+++ b/arch/mips/kernel/cpu-probe.c
|
||||
@@ -753,6 +753,8 @@ static inline void cpu_probe_mips(struct
|
||||
@@ -748,6 +748,8 @@ static inline void cpu_probe_mips(struct
|
||||
case PRID_IMP_25KF:
|
||||
c->cputype = CPU_25KF;
|
||||
__cpu_name[cpu] = "MIPS 25Kc";
|
||||
|
@ -35,7 +35,7 @@
|
|||
c->cputype = CPU_34K;
|
||||
--- a/arch/mips/mm/Makefile
|
||||
+++ b/arch/mips/mm/Makefile
|
||||
@@ -32,6 +32,5 @@ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += c-oct
|
||||
@@ -33,6 +33,5 @@ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += c-oct
|
||||
obj-$(CONFIG_IP22_CPU_SCACHE) += sc-ip22.o
|
||||
obj-$(CONFIG_R5000_CPU_SCACHE) += sc-r5k.o
|
||||
obj-$(CONFIG_RM7000_CPU_SCACHE) += sc-rm7k.o
|
||||
|
@ -44,7 +44,7 @@
|
|||
EXTRA_CFLAGS += -Werror
|
||||
--- a/arch/mips/mm/c-r4k.c
|
||||
+++ b/arch/mips/mm/c-r4k.c
|
||||
@@ -1135,7 +1135,6 @@ static void __init loongson2_sc_init(voi
|
||||
@@ -1148,7 +1148,6 @@ static void __init loongson2_sc_init(voi
|
||||
|
||||
extern int r5k_sc_init(void);
|
||||
extern int rm7k_sc_init(void);
|
||||
|
@ -52,7 +52,7 @@
|
|||
|
||||
static void __cpuinit setup_scache(void)
|
||||
{
|
||||
@@ -1189,29 +1188,17 @@ static void __cpuinit setup_scache(void)
|
||||
@@ -1202,29 +1201,17 @@ static void __cpuinit setup_scache(void)
|
||||
#endif
|
||||
|
||||
default:
|
||||
|
|
|
@ -345,7 +345,7 @@
|
|||
}
|
||||
--- a/arch/mips/mm/tlbex.c
|
||||
+++ b/arch/mips/mm/tlbex.c
|
||||
@@ -784,6 +784,9 @@ static void __cpuinit build_r4000_tlb_re
|
||||
@@ -739,6 +739,9 @@ static void __cpuinit build_r4000_tlb_re
|
||||
/* No need for uasm_i_nop */
|
||||
}
|
||||
|
||||
|
@ -355,7 +355,7 @@
|
|||
#ifdef CONFIG_64BIT
|
||||
build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
|
||||
#else
|
||||
@@ -1238,6 +1241,9 @@ build_r4000_tlbchange_handler_head(u32 *
|
||||
@@ -1193,6 +1196,9 @@ build_r4000_tlbchange_handler_head(u32 *
|
||||
struct uasm_reloc **r, unsigned int pte,
|
||||
unsigned int ptr)
|
||||
{
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/include/asm/cpu-features.h
|
||||
+++ b/arch/mips/include/asm/cpu-features.h
|
||||
@@ -104,6 +104,9 @@
|
||||
@@ -107,6 +107,9 @@
|
||||
#ifndef cpu_has_pindexed_dcache
|
||||
#define cpu_has_pindexed_dcache (cpu_data[0].dcache.flags & MIPS_CACHE_PINDEX)
|
||||
#endif
|
||||
|
@ -28,7 +28,7 @@
|
|||
+#endif /* __ASM_MACH_BCM47XX_CPU_FEATURE_OVERRIDES_H */
|
||||
--- a/arch/mips/mm/c-r4k.c
|
||||
+++ b/arch/mips/mm/c-r4k.c
|
||||
@@ -494,7 +494,7 @@ static inline void local_r4k_flush_cache
|
||||
@@ -507,7 +507,7 @@ static inline void local_r4k_flush_cache
|
||||
*/
|
||||
map_coherent = (cpu_has_dc_aliases &&
|
||||
page_mapped(page) && !Page_dcache_dirty(page));
|
||||
|
@ -37,7 +37,7 @@
|
|||
vaddr = kmap_coherent(page, addr);
|
||||
else
|
||||
vaddr = kmap_atomic(page, KM_USER0);
|
||||
@@ -517,7 +517,7 @@ static inline void local_r4k_flush_cache
|
||||
@@ -530,7 +530,7 @@ static inline void local_r4k_flush_cache
|
||||
}
|
||||
|
||||
if (vaddr) {
|
||||
|
@ -48,7 +48,7 @@
|
|||
kunmap_atomic(vaddr, KM_USER0);
|
||||
--- a/arch/mips/mm/init.c
|
||||
+++ b/arch/mips/mm/init.c
|
||||
@@ -204,7 +204,7 @@ void copy_user_highpage(struct page *to,
|
||||
@@ -209,7 +209,7 @@ void copy_user_highpage(struct page *to,
|
||||
void *vfrom, *vto;
|
||||
|
||||
vto = kmap_atomic(to, KM_USER1);
|
||||
|
@ -57,7 +57,7 @@
|
|||
page_mapped(from) && !Page_dcache_dirty(from)) {
|
||||
vfrom = kmap_coherent(from, vaddr);
|
||||
copy_page(vto, vfrom);
|
||||
@@ -226,7 +226,7 @@ void copy_to_user_page(struct vm_area_st
|
||||
@@ -231,7 +231,7 @@ void copy_to_user_page(struct vm_area_st
|
||||
struct page *page, unsigned long vaddr, void *dst, const void *src,
|
||||
unsigned long len)
|
||||
{
|
||||
|
@ -66,7 +66,7 @@
|
|||
page_mapped(page) && !Page_dcache_dirty(page)) {
|
||||
void *vto = kmap_coherent(page, vaddr) + (vaddr & ~PAGE_MASK);
|
||||
memcpy(vto, src, len);
|
||||
@@ -244,7 +244,7 @@ void copy_from_user_page(struct vm_area_
|
||||
@@ -249,7 +249,7 @@ void copy_from_user_page(struct vm_area_
|
||||
struct page *page, unsigned long vaddr, void *dst, const void *src,
|
||||
unsigned long len)
|
||||
{
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
}
|
||||
|
||||
static void __b44_set_flow_ctrl(struct b44 *bp, u32 pause_flags)
|
||||
@@ -2220,6 +2220,10 @@ static int __devinit b44_init_one(struct
|
||||
@@ -2223,6 +2223,10 @@ static int __devinit b44_init_one(struct
|
||||
*/
|
||||
b44_chip_reset(bp, B44_CHIP_RESET_FULL);
|
||||
|
||||
|
|
|
@ -20,7 +20,7 @@
|
|||
switch (*plltype) {
|
||||
--- a/drivers/ssb/driver_mipscore.c
|
||||
+++ b/drivers/ssb/driver_mipscore.c
|
||||
@@ -161,6 +161,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
|
||||
@@ -217,6 +217,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
|
||||
|
||||
if ((pll_type == SSB_PLLTYPE_5) || (bus->chip_id == 0x5365)) {
|
||||
rate = 200000000;
|
||||
|
@ -31,7 +31,7 @@
|
|||
}
|
||||
--- a/drivers/ssb/main.c
|
||||
+++ b/drivers/ssb/main.c
|
||||
@@ -1010,6 +1010,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
@@ -1066,6 +1066,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
|
||||
|
||||
if (bus->chip_id == 0x5365) {
|
||||
rate = 100000000;
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
--- a/drivers/usb/host/Kconfig
|
||||
+++ b/drivers/usb/host/Kconfig
|
||||
@@ -106,6 +106,19 @@ config USB_OXU210HP_HCD
|
||||
@@ -132,6 +132,19 @@ config USB_OXU210HP_HCD
|
||||
To compile this driver as a module, choose M here: the
|
||||
module will be called oxu210hp-hcd.
|
||||
|
||||
|
@ -29,8 +29,8 @@
|
|||
depends on USB
|
||||
--- a/drivers/usb/host/ehci-hcd.c
|
||||
+++ b/drivers/usb/host/ehci-hcd.c
|
||||
@@ -1075,8 +1075,16 @@ MODULE_LICENSE ("GPL");
|
||||
#define PLATFORM_DRIVER ixp4xx_ehci_driver
|
||||
@@ -1141,8 +1141,16 @@ MODULE_LICENSE ("GPL");
|
||||
#define PLATFORM_DRIVER ehci_atmel_driver
|
||||
#endif
|
||||
|
||||
-#if !defined(PCI_DRIVER) && !defined(PLATFORM_DRIVER) && \
|
||||
|
|
|
@ -5,7 +5,7 @@ This prevents the options from being delete with make kernel_oldconfig.
|
|||
|
||||
--- a/drivers/ssb/Kconfig
|
||||
+++ b/drivers/ssb/Kconfig
|
||||
@@ -126,6 +126,8 @@ config SSB_DRIVER_MIPS
|
||||
@@ -140,6 +140,8 @@ config SSB_DRIVER_MIPS
|
||||
config SSB_EMBEDDED
|
||||
bool
|
||||
depends on SSB_DRIVER_MIPS
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/mm/c-r4k.c
|
||||
+++ b/arch/mips/mm/c-r4k.c
|
||||
@@ -360,7 +360,7 @@ static inline void local_r4k___flush_cac
|
||||
@@ -373,7 +373,7 @@ static inline void local_r4k___flush_cac
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
{
|
||||
r4k_on_each_cpu(local_r4k___flush_cache_all, NULL, 1);
|
||||
}
|
||||
@@ -524,7 +524,7 @@ static inline void local_r4k_flush_cache
|
||||
@@ -537,7 +537,7 @@ static inline void local_r4k_flush_cache
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
unsigned long addr, unsigned long pfn)
|
||||
{
|
||||
struct flush_cache_page_args args;
|
||||
@@ -1443,3 +1443,10 @@ void __cpuinit r4k_cache_init(void)
|
||||
@@ -1456,3 +1456,10 @@ void __cpuinit r4k_cache_init(void)
|
||||
coherency_setup();
|
||||
#endif
|
||||
}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/fs/fuse/dev.c
|
||||
+++ b/fs/fuse/dev.c
|
||||
@@ -527,6 +527,11 @@ static void fuse_copy_finish(struct fuse
|
||||
@@ -533,6 +533,11 @@ static void fuse_copy_finish(struct fuse
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -12,7 +12,7 @@
|
|||
/*
|
||||
* Get another pagefull of userspace buffer, and map it to kernel
|
||||
* address space, and lock request
|
||||
@@ -535,6 +540,9 @@ static int fuse_copy_fill(struct fuse_co
|
||||
@@ -541,6 +546,9 @@ static int fuse_copy_fill(struct fuse_co
|
||||
{
|
||||
unsigned long offset;
|
||||
int err;
|
||||
|
@ -22,7 +22,7 @@
|
|||
|
||||
unlock_request(cs->fc, cs->req);
|
||||
fuse_copy_finish(cs);
|
||||
@@ -546,14 +554,22 @@ static int fuse_copy_fill(struct fuse_co
|
||||
@@ -552,14 +560,22 @@ static int fuse_copy_fill(struct fuse_co
|
||||
cs->nr_segs--;
|
||||
}
|
||||
down_read(¤t->mm->mmap_sem);
|
||||
|
@ -45,7 +45,7 @@
|
|||
cs->buf = cs->mapaddr + offset;
|
||||
cs->len = min(PAGE_SIZE - offset, cs->seglen);
|
||||
cs->seglen -= cs->len;
|
||||
@@ -567,6 +583,11 @@ static int fuse_copy_do(struct fuse_copy
|
||||
@@ -573,6 +589,11 @@ static int fuse_copy_do(struct fuse_copy
|
||||
{
|
||||
unsigned ncpy = min(*size, cs->len);
|
||||
if (val) {
|
||||
|
@ -69,7 +69,7 @@
|
|||
#include <linux/fs.h>
|
||||
--- a/fs/fuse/inode.c
|
||||
+++ b/fs/fuse/inode.c
|
||||
@@ -1055,6 +1055,10 @@ static int __init fuse_init(void)
|
||||
@@ -1201,6 +1201,10 @@ static int __init fuse_init(void)
|
||||
printk(KERN_INFO "fuse init (API version %i.%i)\n",
|
||||
FUSE_KERNEL_VERSION, FUSE_KERNEL_MINOR_VERSION);
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/include/asm/page.h
|
||||
+++ b/arch/mips/include/asm/page.h
|
||||
@@ -35,6 +35,7 @@
|
||||
@@ -43,6 +43,7 @@
|
||||
#ifndef __ASSEMBLY__
|
||||
|
||||
#include <linux/pfn.h>
|
||||
|
@ -8,7 +8,7 @@
|
|||
#include <asm/io.h>
|
||||
|
||||
extern void build_clear_page(void);
|
||||
@@ -70,13 +71,16 @@ static inline void clear_user_page(void
|
||||
@@ -78,13 +79,16 @@ static inline void clear_user_page(void
|
||||
flush_data_cache_page((unsigned long)addr);
|
||||
}
|
||||
|
||||
|
@ -33,7 +33,7 @@
|
|||
* These are used to make use of C type-checking..
|
||||
--- a/arch/mips/mm/init.c
|
||||
+++ b/arch/mips/mm/init.c
|
||||
@@ -198,30 +198,6 @@ void kunmap_coherent(void)
|
||||
@@ -203,30 +203,6 @@ void kunmap_coherent(void)
|
||||
preempt_check_resched();
|
||||
}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -53,6 +53,7 @@ config BCM47XX
|
||||
@@ -74,6 +74,7 @@ config BCM47XX
|
||||
select SSB_DRIVER_MIPS
|
||||
select SSB_DRIVER_EXTIF
|
||||
select SSB_EMBEDDED
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
#include <net/checksum.h>
|
||||
#include <net/ip.h>
|
||||
@@ -446,8 +447,9 @@ static void _tw32_flush(struct tg3 *tp,
|
||||
@@ -457,8 +458,9 @@ static void _tw32_flush(struct tg3 *tp,
|
||||
static inline void tw32_mailbox_flush(struct tg3 *tp, u32 off, u32 val)
|
||||
{
|
||||
tp->write32_mbox(tp, off, val);
|
||||
|
@ -20,7 +20,7 @@
|
|||
tp->read32_mbox(tp, off);
|
||||
}
|
||||
|
||||
@@ -457,7 +459,7 @@ static void tg3_write32_tx_mbox(struct t
|
||||
@@ -468,7 +470,7 @@ static void tg3_write32_tx_mbox(struct t
|
||||
writel(val, mbox);
|
||||
if (tp->tg3_flags & TG3_FLAG_TXD_MBOX_HWBUG)
|
||||
writel(val, mbox);
|
||||
|
@ -29,7 +29,7 @@
|
|||
readl(mbox);
|
||||
}
|
||||
|
||||
@@ -729,7 +731,7 @@ static void tg3_switch_clocks(struct tg3
|
||||
@@ -768,7 +770,7 @@ static void tg3_switch_clocks(struct tg3
|
||||
|
||||
#define PHY_BUSY_LOOPS 5000
|
||||
|
||||
|
@ -38,7 +38,7 @@
|
|||
{
|
||||
u32 frame_val;
|
||||
unsigned int loops;
|
||||
@@ -778,7 +780,12 @@ static int tg3_readphy(struct tg3 *tp, i
|
||||
@@ -817,7 +819,12 @@ static int tg3_readphy(struct tg3 *tp, i
|
||||
return ret;
|
||||
}
|
||||
|
||||
|
@ -52,7 +52,7 @@
|
|||
{
|
||||
u32 frame_val;
|
||||
unsigned int loops;
|
||||
@@ -827,6 +834,11 @@ static int tg3_writephy(struct tg3 *tp,
|
||||
@@ -866,6 +873,11 @@ static int tg3_writephy(struct tg3 *tp,
|
||||
return ret;
|
||||
}
|
||||
|
||||
|
@ -64,7 +64,7 @@
|
|||
static int tg3_bmcr_reset(struct tg3 *tp)
|
||||
{
|
||||
u32 phy_control;
|
||||
@@ -2263,6 +2275,9 @@ static int tg3_nvram_read(struct tg3 *tp
|
||||
@@ -2337,6 +2349,9 @@ static int tg3_nvram_read(struct tg3 *tp
|
||||
{
|
||||
int ret;
|
||||
|
||||
|
@ -74,7 +74,7 @@
|
|||
if (!(tp->tg3_flags & TG3_FLAG_NVRAM))
|
||||
return tg3_nvram_read_using_eeprom(tp, offset, val);
|
||||
|
||||
@@ -2594,8 +2609,10 @@ static int tg3_set_power_state(struct tg
|
||||
@@ -2668,8 +2683,10 @@ static int tg3_set_power_state(struct tg
|
||||
tg3_frob_aux_power(tp);
|
||||
|
||||
/* Workaround for unstable PLL clock */
|
||||
|
@ -87,7 +87,7 @@
|
|||
u32 val = tr32(0x7d00);
|
||||
|
||||
val &= ~((1 << 16) | (1 << 4) | (1 << 2) | (1 << 1) | 1);
|
||||
@@ -3087,6 +3104,14 @@ relink:
|
||||
@@ -3161,6 +3178,14 @@ relink:
|
||||
|
||||
tg3_phy_copper_begin(tp);
|
||||
|
||||
|
@ -102,7 +102,7 @@
|
|||
tg3_readphy(tp, MII_BMSR, &tmp);
|
||||
if (!tg3_readphy(tp, MII_BMSR, &tmp) &&
|
||||
(tmp & BMSR_LSTATUS))
|
||||
@@ -6000,6 +6025,11 @@ static int tg3_poll_fw(struct tg3 *tp)
|
||||
@@ -6264,6 +6289,11 @@ static int tg3_poll_fw(struct tg3 *tp)
|
||||
int i;
|
||||
u32 val;
|
||||
|
||||
|
@ -114,7 +114,7 @@
|
|||
if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5906) {
|
||||
/* Wait up to 20ms for init done. */
|
||||
for (i = 0; i < 200; i++) {
|
||||
@@ -6257,6 +6287,14 @@ static int tg3_chip_reset(struct tg3 *tp
|
||||
@@ -6541,6 +6571,14 @@ static int tg3_chip_reset(struct tg3 *tp
|
||||
tw32(0x5000, 0x400);
|
||||
}
|
||||
|
||||
|
@ -129,7 +129,7 @@
|
|||
tw32(GRC_MODE, tp->grc_mode);
|
||||
|
||||
if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
|
||||
@@ -6409,9 +6447,12 @@ static int tg3_halt_cpu(struct tg3 *tp,
|
||||
@@ -6695,9 +6733,12 @@ static int tg3_halt_cpu(struct tg3 *tp,
|
||||
return -ENODEV;
|
||||
}
|
||||
|
||||
|
@ -145,7 +145,7 @@
|
|||
return 0;
|
||||
}
|
||||
|
||||
@@ -6474,6 +6515,11 @@ static int tg3_load_5701_a0_firmware_fix
|
||||
@@ -6760,6 +6801,11 @@ static int tg3_load_5701_a0_firmware_fix
|
||||
const __be32 *fw_data;
|
||||
int err, i;
|
||||
|
||||
|
@ -157,7 +157,7 @@
|
|||
fw_data = (void *)tp->fw->data;
|
||||
|
||||
/* Firmware blob starts with version numbers, followed by
|
||||
@@ -6533,6 +6579,11 @@ static int tg3_load_tso_firmware(struct
|
||||
@@ -6819,6 +6865,11 @@ static int tg3_load_tso_firmware(struct
|
||||
unsigned long cpu_base, cpu_scratch_base, cpu_scratch_size;
|
||||
int err, i;
|
||||
|
||||
|
@ -169,7 +169,7 @@
|
|||
if (tp->tg3_flags2 & TG3_FLG2_HW_TSO)
|
||||
return 0;
|
||||
|
||||
@@ -7444,6 +7495,11 @@ static void tg3_timer(unsigned long __op
|
||||
@@ -7906,6 +7957,11 @@ static void tg3_timer(unsigned long __op
|
||||
|
||||
spin_lock(&tp->lock);
|
||||
|
||||
|
@ -181,7 +181,7 @@
|
|||
if (!(tp->tg3_flags & TG3_FLAG_TAGGED_STATUS)) {
|
||||
/* All of this garbage is because when using non-tagged
|
||||
* IRQ status the mailbox/status_block protocol the chip
|
||||
@@ -9217,6 +9273,11 @@ static int tg3_test_nvram(struct tg3 *tp
|
||||
@@ -9791,6 +9847,11 @@ static int tg3_test_nvram(struct tg3 *tp
|
||||
if (tp->tg3_flags3 & TG3_FLG3_NO_NVRAM)
|
||||
return 0;
|
||||
|
||||
|
@ -193,7 +193,7 @@
|
|||
if (tg3_nvram_read(tp, 0, &magic) != 0)
|
||||
return -EIO;
|
||||
|
||||
@@ -10010,7 +10071,7 @@ static int tg3_ioctl(struct net_device *
|
||||
@@ -10585,7 +10646,7 @@ static int tg3_ioctl(struct net_device *
|
||||
return -EAGAIN;
|
||||
|
||||
spin_lock_bh(&tp->lock);
|
||||
|
@ -202,7 +202,7 @@
|
|||
spin_unlock_bh(&tp->lock);
|
||||
|
||||
data->val_out = mii_regval;
|
||||
@@ -10029,7 +10090,7 @@ static int tg3_ioctl(struct net_device *
|
||||
@@ -10601,7 +10662,7 @@ static int tg3_ioctl(struct net_device *
|
||||
return -EAGAIN;
|
||||
|
||||
spin_lock_bh(&tp->lock);
|
||||
|
@ -211,7 +211,7 @@
|
|||
spin_unlock_bh(&tp->lock);
|
||||
|
||||
return err;
|
||||
@@ -10619,6 +10680,12 @@ static void __devinit tg3_get_57780_nvra
|
||||
@@ -11246,6 +11307,12 @@ static void __devinit tg3_get_5717_nvram
|
||||
/* Chips other than 5700/5701 use the NVRAM for fetching info. */
|
||||
static void __devinit tg3_nvram_init(struct tg3 *tp)
|
||||
{
|
||||
|
@ -224,7 +224,7 @@
|
|||
tw32_f(GRC_EEPROM_ADDR,
|
||||
(EEPROM_ADDR_FSM_RESET |
|
||||
(EEPROM_DEFAULT_CLOCK_PERIOD <<
|
||||
@@ -10877,6 +10944,9 @@ static int tg3_nvram_write_block(struct
|
||||
@@ -11506,6 +11573,9 @@ static int tg3_nvram_write_block(struct
|
||||
{
|
||||
int ret;
|
||||
|
||||
|
@ -234,7 +234,7 @@
|
|||
if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
|
||||
tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
|
||||
~GRC_LCLCTRL_GPIO_OUTPUT1);
|
||||
@@ -12136,6 +12205,11 @@ static int __devinit tg3_get_invariants(
|
||||
@@ -12788,6 +12858,11 @@ static int __devinit tg3_get_invariants(
|
||||
GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
|
||||
tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
|
||||
|
||||
|
@ -246,7 +246,7 @@
|
|||
/* Get eeprom hw config before calling tg3_set_power_state().
|
||||
* In particular, the TG3_FLG2_IS_NIC flag must be
|
||||
* determined before calling tg3_set_power_state() so that
|
||||
@@ -12513,6 +12587,10 @@ static int __devinit tg3_get_device_addr
|
||||
@@ -13177,6 +13252,10 @@ static int __devinit tg3_get_device_addr
|
||||
}
|
||||
|
||||
if (!is_valid_ether_addr(&dev->dev_addr[0])) {
|
||||
|
@ -257,7 +257,7 @@
|
|||
#ifdef CONFIG_SPARC
|
||||
if (!tg3_get_default_macaddr_sparc(tp))
|
||||
return 0;
|
||||
@@ -13004,6 +13082,7 @@ static char * __devinit tg3_phy_string(s
|
||||
@@ -13669,6 +13748,7 @@ static char * __devinit tg3_phy_string(s
|
||||
case PHY_ID_BCM5704: return "5704";
|
||||
case PHY_ID_BCM5705: return "5705";
|
||||
case PHY_ID_BCM5750: return "5750";
|
||||
|
@ -265,7 +265,7 @@
|
|||
case PHY_ID_BCM5752: return "5752";
|
||||
case PHY_ID_BCM5714: return "5714";
|
||||
case PHY_ID_BCM5780: return "5780";
|
||||
@@ -13214,6 +13293,13 @@ static int __devinit tg3_init_one(struct
|
||||
@@ -13880,6 +13960,13 @@ static int __devinit tg3_init_one(struct
|
||||
tp->msg_enable = tg3_debug;
|
||||
else
|
||||
tp->msg_enable = TG3_DEF_MSG_ENABLE;
|
||||
|
@ -281,7 +281,7 @@
|
|||
* swapping. DMA data byte swapping is controlled in the GRC_MODE
|
||||
--- a/drivers/net/tg3.h
|
||||
+++ b/drivers/net/tg3.h
|
||||
@@ -1853,6 +1853,9 @@
|
||||
@@ -1939,6 +1939,9 @@
|
||||
#define NIC_SRAM_RGMII_STD_IBND_DISABLE 0x00000004
|
||||
#define NIC_SRAM_RGMII_EXT_IBND_RX_EN 0x00000008
|
||||
#define NIC_SRAM_RGMII_EXT_IBND_TX_EN 0x00000010
|
||||
|
@ -291,7 +291,7 @@
|
|||
|
||||
#define NIC_SRAM_RX_MINI_BUFFER_DESC 0x00001000
|
||||
|
||||
@@ -2701,6 +2704,7 @@ struct tg3 {
|
||||
@@ -2821,6 +2824,7 @@ struct tg3 {
|
||||
#define PHY_ID_BCM5714 0x60008340
|
||||
#define PHY_ID_BCM5780 0x60008350
|
||||
#define PHY_ID_BCM5755 0xbc050cc0
|
||||
|
@ -299,7 +299,7 @@
|
|||
#define PHY_ID_BCM5787 0xbc050ce0
|
||||
#define PHY_ID_BCM5756 0xbc050ed0
|
||||
#define PHY_ID_BCM5784 0xbc050fa0
|
||||
@@ -2745,7 +2749,7 @@ struct tg3 {
|
||||
@@ -2865,7 +2869,7 @@ struct tg3 {
|
||||
(X) == PHY_ID_BCM5780 || (X) == PHY_ID_BCM5787 || \
|
||||
(X) == PHY_ID_BCM5755 || (X) == PHY_ID_BCM5756 || \
|
||||
(X) == PHY_ID_BCM5906 || (X) == PHY_ID_BCM5761 || \
|
||||
|
|
|
@ -88,9 +88,9 @@
|
|||
-static __init void prom_init_cmdline(void)
|
||||
+static __init void prom_init_cmdline_cfe(void)
|
||||
{
|
||||
char buf[CL_SIZE];
|
||||
static char buf[CL_SIZE] __initdata;
|
||||
|
||||
@@ -146,9 +122,12 @@ static __init void prom_init_mem(void)
|
||||
@@ -154,9 +130,12 @@ static __init void prom_init_mem(void)
|
||||
|
||||
void __init prom_init(void)
|
||||
{
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -56,7 +56,6 @@ config BCM47XX
|
||||
@@ -77,7 +77,6 @@ config BCM47XX
|
||||
select SSB_B43_PCI_BRIDGE if PCI
|
||||
select SSB_PCICORE_HOSTMODE if PCI
|
||||
select GENERIC_GPIO
|
||||
|
|
|
@ -31,7 +31,7 @@
|
|||
|
||||
--- a/arch/mips/mm/tlbex.c
|
||||
+++ b/arch/mips/mm/tlbex.c
|
||||
@@ -544,6 +544,9 @@ build_get_pgde32(u32 **p, unsigned int t
|
||||
@@ -601,6 +601,9 @@ build_get_pgde32(u32 **p, unsigned int t
|
||||
#endif
|
||||
uasm_i_addu(p, ptr, tmp, ptr);
|
||||
#else
|
||||
|
@ -41,7 +41,7 @@
|
|||
UASM_i_LA_mostly(p, ptr, pgdc);
|
||||
#endif
|
||||
uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
|
||||
@@ -674,12 +677,12 @@ static void __cpuinit build_r4000_tlb_re
|
||||
@@ -739,12 +742,12 @@ static void __cpuinit build_r4000_tlb_re
|
||||
/* No need for uasm_i_nop */
|
||||
}
|
||||
|
||||
|
@ -57,7 +57,7 @@
|
|||
build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
|
||||
#endif
|
||||
|
||||
@@ -687,6 +690,9 @@ static void __cpuinit build_r4000_tlb_re
|
||||
@@ -756,6 +759,9 @@ static void __cpuinit build_r4000_tlb_re
|
||||
build_update_entries(&p, K0, K1);
|
||||
build_tlb_write_entry(&p, &l, &r, tlb_random);
|
||||
uasm_l_leave(&l, p);
|
||||
|
@ -66,8 +66,8 @@
|
|||
+#endif
|
||||
uasm_i_eret(&p); /* return from trap */
|
||||
|
||||
#ifdef CONFIG_64BIT
|
||||
@@ -1084,12 +1090,12 @@ build_r4000_tlbchange_handler_head(u32 *
|
||||
#ifdef CONFIG_HUGETLB_PAGE
|
||||
@@ -1196,12 +1202,12 @@ build_r4000_tlbchange_handler_head(u32 *
|
||||
struct uasm_reloc **r, unsigned int pte,
|
||||
unsigned int ptr)
|
||||
{
|
||||
|
@ -83,7 +83,7 @@
|
|||
build_get_pgde32(p, pte, ptr); /* get pgd in ptr */
|
||||
#endif
|
||||
|
||||
@@ -1117,6 +1123,9 @@ build_r4000_tlbchange_handler_tail(u32 *
|
||||
@@ -1238,6 +1244,9 @@ build_r4000_tlbchange_handler_tail(u32 *
|
||||
build_update_entries(p, tmp, ptr);
|
||||
build_tlb_write_entry(p, l, r, tlb_indexed);
|
||||
uasm_l_leave(l, *p);
|
||||
|
|
Loading…
Reference in a new issue