ipq806x: rename R7800 device tree file, merge R7500v2 dts addition

The R7800 is an IPQ8065, so rename its dts file to reflect that fact.
Also fold the R7500v2 dts addition into the existing 800-devicetree.patch.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
Jo-Philipp Wich 2016-08-24 01:35:22 +02:00
parent 212c6bd781
commit 00e8571f2b
4 changed files with 4 additions and 13 deletions

View file

@ -190,7 +190,7 @@ endef
define Device/R7800 define Device/R7800
$(call Device/DniImage) $(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-r7800 DEVICE_DTS := qcom-ipq8065-r7800
KERNEL_SIZE := 2097152 KERNEL_SIZE := 2097152
NETGEAR_BOARD_ID := R7800 NETGEAR_BOARD_ID := R7800
NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade

View file

@ -12,7 +12,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -506,7 +506,12 @@ dtb-$(CONFIG_ARCH_QCOM) += \ @@ -506,7 +506,13 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8084-ifc6540.dtb \ qcom-apq8084-ifc6540.dtb \
qcom-apq8084-mtp.dtb \ qcom-apq8084-mtp.dtb \
qcom-ipq8064-ap148.dtb \ qcom-ipq8064-ap148.dtb \
@ -21,7 +21,8 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
qcom-ipq8064-db149.dtb \ qcom-ipq8064-db149.dtb \
+ qcom-ipq8064-ea8500.dtb \ + qcom-ipq8064-ea8500.dtb \
+ qcom-ipq8064-r7500.dtb \ + qcom-ipq8064-r7500.dtb \
+ qcom-ipq8064-r7800.dtb \ + qcom-ipq8064-r7500v2.dtb \
+ qcom-ipq8065-r7800.dtb \
qcom-msm8660-surf.dtb \ qcom-msm8660-surf.dtb \
qcom-msm8960-cdp.dtb \ qcom-msm8960-cdp.dtb \
qcom-msm8974-sony-xperia-honami.dtb qcom-msm8974-sony-xperia-honami.dtb

View file

@ -1,10 +0,0 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -511,6 +511,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-ipq8064-db149.dtb \
qcom-ipq8064-ea8500.dtb \
qcom-ipq8064-r7500.dtb \
+ qcom-ipq8064-r7500v2.dtb \
qcom-ipq8064-r7800.dtb \
qcom-msm8660-surf.dtb \
qcom-msm8960-cdp.dtb \