refresh 2.6.30 kernel patches

SVN-Revision: 18231
This commit is contained in:
Florian Fainelli 2009-10-30 16:24:52 +00:00
parent 12d8c25efe
commit 0000c40d8f
5 changed files with 12 additions and 16 deletions

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -112,6 +112,50 @@ config MTD_SUN_UFLASH
@@ -123,6 +123,50 @@ config MTD_SUN_UFLASH
Sun Microsystems boardsets. This driver will require CFI support
in the kernel, so if you did not enable CFI previously, do that now.

View file

@ -1,6 +1,6 @@
--- a/init/do_mounts.c
+++ b/init/do_mounts.c
@@ -189,6 +189,8 @@ static void __init get_fs_names(char *pa
@@ -191,6 +191,8 @@ static void __init get_fs_names(char *pa
{
char *s = page;

View file

@ -21,7 +21,7 @@
/*
* Invoke the realmode switch hook if present; otherwise
@@ -156,6 +159,16 @@ void go_to_protected_mode(void)
@@ -112,6 +115,16 @@ void go_to_protected_mode(void)
die();
}

View file

@ -1,8 +1,6 @@
Index: linux-2.6.29.5/drivers/mtd/maps/Kconfig
===================================================================
--- linux-2.6.29.5.orig/drivers/mtd/maps/Kconfig 2009-06-19 11:26:44.000000000 +0200
+++ linux-2.6.29.5/drivers/mtd/maps/Kconfig 2009-06-19 11:26:45.000000000 +0200
@@ -167,6 +167,12 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -167,6 +167,12 @@ config MTD_RDC3210_BUSWIDTH
Number of bytes addressed on the RDC-3210 flash device before
addressing the same chip again
@ -15,11 +13,9 @@ Index: linux-2.6.29.5/drivers/mtd/maps/Kconfig
config MTD_SC520CDP
tristate "CFI Flash device mapped on AMD SC520 CDP"
depends on X86 && MTD_CFI && MTD_CONCAT
Index: linux-2.6.29.5/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.29.5.orig/drivers/mtd/maps/Makefile 2009-06-19 11:26:44.000000000 +0200
+++ linux-2.6.29.5/drivers/mtd/maps/Makefile 2009-06-19 11:26:45.000000000 +0200
@@ -28,6 +28,7 @@
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -28,6 +28,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
obj-$(CONFIG_MTD_RDC3210) += rdc3210.o

View file

@ -1,6 +1,6 @@
--- a/arch/x86/Kconfig 2009-06-19 15:06:16.000000000 +0200
+++ b/arch/x86/Kconfig 2009-06-19 15:06:01.000000000 +0200
@@ -380,6 +380,7 @@
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -380,6 +380,7 @@ config X86_RDC321X
depends on X86_EXTENDED_PLATFORM
select M486
select X86_REBOOTFIXUPS